Moyenne pondérée [Résolu/Fermé]

Signaler
Messages postés
17
Date d'inscription
jeudi 21 septembre 2017
Statut
Membre
Dernière intervention
16 avril 2019
-
Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
-
Bonjour,

Je veux calculer la moyenne de différentes variables en prenant en considération le nombre des produits. Le lien ci-dessous explique mieux ou j'ai eu le blocage. Si quelqu'un peut m'aider.

Merci d'avance

https://www.cjoint.com/c/HCdlGuQOJeD
A voir également:

4 réponses

Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
5 995
Bonjour
oui, ça fonctionnera
mais si vous avez Excel 2007 ou + pour faire court:

=SIERREUR(SOMMEPROD(D2:D4)*(G2:G4)/SOMME(G2:G4);"")

et n'oubliez pas de bloquer G2:G4 > $G$2:$G$4 si vous tirer vers la droite

crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
5 995
Bonjour
on ne sait pas trop sur quelle base vous voulez calculer la moyenne, mais si c'est au M2 par rapport aux nombres de propositions, essayez avec, en D5, à tirer vers la droite

=SOMMEPROD((D2:D4)*($G$2:$G$4))/SOMME($G$2:$G$4)
attention à la position des $ pour pouvoir tirer la formule

et revenez avec plus de précisions si ça ne convient pas

crdlmnt
Messages postés
17
Date d'inscription
jeudi 21 septembre 2017
Statut
Membre
Dernière intervention
16 avril 2019

Merci pour le retour Vaucluse,

Alors je vais vous expliquer à travers un exemple :

Col A : Types d'actif immobilier
Col B : L'usage (Commercial, ...)
Col C : Nombre d'étage
Col D : Superficie m²
Col E : Prix total pour chaque type
Col F : Prix unitaire/m²
Col G : Nombre d'actif pour chaque type

Ce que je recherche est de pouvoir calculer la moyenne de toutes les superficies, prix total, et prix unitaire des différents types en prenant en considération le nombre total des actifs immobiliers.
Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
5 995
ceci ne dit pas si la formule que je propose par rapport au modèle que vous avez déposé correspond à une partie au moins de votre attente?
sachant que cette proposition fait la moyenne dans chaque rubrique D E F selon le nombre total de produit en G

si vous voulez y rajouter la sélection du type A, il suufira de rajouter les infos à la formule:
=SOMMEPROD(($A$2:$A$4="type cherché")*(D2:D4)*($G$2:$G$4))/SOMMEPROD((A2:A4="Typecherché")*($G$2:$G$4))

limitez bien les hauteurs de champs aux lignes utiles pour ne pas alourdir le fichier

et si ça ne convient pas, renvoyez un fichier avec un exemple de résultat attendu.

à vous lire

crdlmnt
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
6 845
Bonjour,

voir MOYENNE.SI(), ou bien avec un TCD.
eric

Edit : je n'avais pas vu ton fichier.
Qu'est-ce qui ne te plait pas dans la proposition de vaucluse ?
Si tu as pris la peine de la tester bien sûr...

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
J'ai testée mais ça me donne DIV0
Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
5 995
ah bon? alors vous ne devez pas l'utiliser sur le fichier que vous avez fourni:
voyez ici:
https://mon-partage.fr/f/7ThLuiBY/

mais bien sur ça ne garantit pas que ce soit ce que vous cherchez
Messages postés
17
Date d'inscription
jeudi 21 septembre 2017
Statut
Membre
Dernière intervention
16 avril 2019

Bonjour Vaucluse,
Est ce que je peux utiliser cette formule :
=SI(ESTERREUR(SOMMEPROD(D2:D4)*(G2:G4)/SOMME(G2:G4);"";SOMMEPROD(D2:D4)*(G2:G4)/SOMME(G2:G4))

pour éviter le DIV0


Cordialement
Messages postés
17
Date d'inscription
jeudi 21 septembre 2017
Statut
Membre
Dernière intervention
16 avril 2019

Voici le fichier Vaucluse j'arrive toujours pas à résoudre l'erreur. :(

https://www.cjoint.com/c/HCfjBROKOdp
Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
5 995
fichier en retour avec la suppression de l'affichage d'erreur ( qui existe tant que le champ sommé en G ne contient pas de valeur
https://mon-partage.fr/f/Gxaiw1qZ/
crdlmnt
Messages postés
17
Date d'inscription
jeudi 21 septembre 2017
Statut
Membre
Dernière intervention
16 avril 2019

Ça marche maintenant, je vous remercie pour votre aide.
Messages postés
26111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juillet 2021
5 995
Pas de quoi.
Si ça vous convient, merci de passer le sujet en résolu
(menu roue dentée en haut du fil à droite)
bonne route
crdlmnt