Mise en forme conditionnelle texte

Résolu/Fermé
Evedll
Messages postés
72
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
25 octobre 2018
- 6 févr. 2018 à 10:22
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 6 févr. 2018 à 13:44
Bonjour,
J'utilise excel 2010 et j'ai besoin d'appliquer une mise en forme conditionnelle.
Critère en colonne F : contient "en 18",il faut appliquer un format sur les lignes correspondant à ce critère.
Il faut savoir que dans la cellule, le texte peut être : "soldé en 18", "remb en 18" ou autre qui contient "en 18".
Après certaines recherche, je ne trouve pas la réponse. Merci de m'aider.
Cordialement
Eve
A voir également:

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
6 févr. 2018 à 10:33
Bonjour
MFC par formule
icône MFC nouvelle règle / "utiliser une formule.."
sélectionner le champ ou la plage

si par exemple il commence en F2,formule de MFC:

=NB.SI($F2;"*en 18*")

attention aux signes n'oubliez pas les *

crdlmnt

2
Evedll
Messages postés
72
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
25 octobre 2018

6 févr. 2018 à 13:28
Bonjour Vaucluse,
Merci de ton aide. Je n'aurai jamais pensé utiliser la fonction NB.SI pour ce type de MFC car je voulais une mise en forme trame de fond et pour moi, cette formule me donne un chiffre et non un format.
Au départ, j'ai pensé que tu avais mal compris ma demande alors que pas du tout. En ce qui concerne les étoiles, j'aurais dû y penser.
Cela fonctionne très bien
Encore merci
Eve
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
6 févr. 2018 à 13:44
Pas de quoi
au delà du résultat num de la formule , elle dit aussi non si 0 et oui si <>0
d'où cette utilisation

pour info pour les étoiles:
  • ;"texte*" le texte commence par
  • ;"*texte" le texte finit par
  • ;"'*texte*" le texte est inclus


si texte dans une cellule:

="*"&cell&"*"

etc....
bonne route
bien cordialement
0