Définir des valeurs à une cellule [Résolu/Fermé]

Signaler
Messages postés
971
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
8 septembre 2019
-
Messages postés
971
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
8 septembre 2019
-
Bonjour,

Je cherche depuis un moment une solution à mon problème mais je ne trouve pas...

Voila j'ai un tableau avec des produits en commande.
J'ai une colonne, quantité et à côté une autre colonne prix, je souhaiterais que la cellule prix change lorsque l'on modifie le nombre dans quantité.

Exemple :

quantité 0 prix 0
quantité 1 prix 52
quantité 2 prix 104

Ce ne doit pas être compliqué mais j'utilise très peu Excel donc pas facile..

Merci par avance.

2 réponses

Messages postés
1658
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
22 juin 2020
443
Salut,

La base de la base d'Excel : en A1, tu mets la quantité, en A2, le prix à l'unité et en A3 le calcul c'est à dire
=A1*A2

Si le prix à l'unité varie en fonction de la quantité, dans ce cas, soit tu as une règle mathématique, soit tu passe par la fonction SI ou SI MULTIPLE

Messages postés
971
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
8 septembre 2019
78
Bonjour,

Merci pour l'info, la formule m'aidera partiellement. Je vais compléter la suite du tableau avec la réponse de Mike-31.

Bien cordialement.
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 132
Bonsoir,

si ta première quantité est en A2 en B2 colle cette formule
=52*A2
ou
=SI(A2>0;52*A2;0)

ensuite incrémente la formule vers le bas
mais le prix unitaire 52 est certainement dans une cellule exemple en F1
la formule devient
=SI(A2>0;F1*A2;0)
il est possible de compléter la formule pour éviter l'affichage 0 lorsque les cellules colonne A sont vides
=SI(A2<>"";52*A2;"")
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
971
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
8 septembre 2019
78
Bonjour,

Merci pour l'aide, j'ai pu finir le tableau comme je le souhaitais.

Bien cordialement.