Formule de recherche dans plusieurs feuilles d'un fichier Excel

Fermé
jacki - 10 janv. 2018 à 15:03
jacki159
Messages postés
2
Date d'inscription
mercredi 10 janvier 2018
Statut
Membre
Dernière intervention
19 janvier 2018
- 10 janv. 2018 à 15:33
Bonjour,

Je rencontre un problème dans un fichier excel.
J'ai un fichier avec 3 feuilles
dans la première j'ai en colonne A le numéro de pièce et j'aimerais connaitre le prix de la pièce qui devrait apparaitre dans la colonne D.
Mes chiffres se trouvent dans la feuille B ich j'ai toute la liste de prix pour tous les articles mais évidemment il y a plus de lignes que sur la première feuille.
Pour la troisième feuille elle ressemble à la seconde mais à une autre liste de prix que je devrais pouvoir faire entrer dans la première feuille mais colonne G.
Quelqu'un peut m'aider s'il vous plait
A voir également:

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 266
Modifié le 10 janv. 2018 à 15:10
Bonjour
sans plus d'info, à adapter pour aller chercher un résultat en feuil2 ou feuil3

en feuil1le tableau à remplir avec le code article en A2 et la valeur à resortir (La formule donc) en D2
en feuil2 une liste de code en A et de prix en B
en feuil3 idem, avec d'autres codes

la formule en D2:

=SIERREUR(RECHERCHEV(A2;SI(NB.SI(feuil2!A:A;A2);feuil2!A:B;feuil3!A:B);2;0);"")
le SIERREUR(formule);"")
est destiné à éviter un affichage d'erreur si A2 est vide ou si le code n'existe dans aucune des deux feuilles (fonctionne à partir d'Excel 2007)

à adapter bien sur à vos données

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
jacki159
Messages postés
2
Date d'inscription
mercredi 10 janvier 2018
Statut
Membre
Dernière intervention
19 janvier 2018

10 janv. 2018 à 15:33
Oh trop bien merci. ça fonctionne avec la feuille un et deux la trois pas encore réussi
0