Mise en forme conditionnelle uniquement jours semaine [Résolu/Fermé]

Signaler
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020
-
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
-
Bonjour,

j'essaye de créer une feuille horaire à l'année et je voudrais mettre les jours de weekend d'une couleurs, çà c'est fait, et les autres jours de la semaine de couleurs différentes, mais je ne sais pas quelle formule utiliser.

je laisse un fichier en pièce jointe.... Merci beaucoup pour vos aides qui me font progresser à chaque fois....

https://www.cjoint.com/c/GLnksVy5zls

4 réponses

Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 527
Bonjour

??? quel est votre problème, utiliser la formule qui traite des jours de WE avec :

=$B7="L" pour lundi
et idem pour les autres jours si vous voulez des couleurs différentes.

sinon pour une seule couleur pour tous les jours
=ET(B7<>"";B7<>"S";B7<>"D")

mais vous pouvez aussi utiliser directement sans passer par B les dates avec la formule:

=JOURSEM($A7;2)=1 pour lundi, 2 pour mardi Etc...

crdlmnt



Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020

voilà la formule que j'ai mise mais elle ne marche pas...

=($B7="L";$B7="M";$B7="Me";$B7="J";$B7="V")
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020

j'avais oublié le "ou" merci ça marche....

est-ce compliquer de déclencher une formule uniquement en fin de mois ou de semaine ?

pour éviter quand on change d'année de refaire la mise en page....

Merci
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 527
Que voulez vous faire exactement?
, pour changer d'année il suffit de placer en B1 (ou ailleurs) l'année voulue

et en A1 la formule:

=DATE(B1;1;1)

il restera à aligner le 1° jour dans la première semaine, puisque ce ne sera pas forcément un lundi

Alors vous pouvez adopter en A7

=A1-JOURSEM(A1;2)+1

qui vous donnera en A7 la date du lundi de la semaine qui contient le 1° janvier, ainsi le tableau s'ajuste à chaque année en B1

crdlmnt
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 527
Alors vous avez deux solutions puisqu'il semble que vous vouliez une couleur identique pour tous les jours:

soit la formule:
=OU($B7="L";$B7="M"$;B7="Me";$B7="J";$B7="V")

ou tout simplement
=$B7<>""

ligne de formule à placer au dessous de celle des WE, avec les flèches ascenseur de la fenêtre de MFC.
Avec ça, vous placerez le format sur toutes les lignes qui contiennent une valeur en B sauf celle de S et D dont la MFC sera prioritaire.

Pour info, à toutes fins utiles:
il y a moyen si vous faites une liste de référence, de formater aussi différemment les jours fériés à partir de la date en A
avec:
=NB.SI(liste jours fériés;$A7)
à placer au 2° rang
  • donc S et D au 1°, rang
  • Jours fériés au second rang
  • le reste au dernier rang


crdlmnt

Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 527
Re
la formule pour les jours fériés ne fonctionne pas, essentiellement, je pense parce que votre liste de JF est en 2017 et votre calendrier en 2018 :-, mais si vous avez un ancien Excel, il est aussi possible qu'il faille nommer le champ de jours fériés pour utiliser le nom dans la formule de MFC. Quel est "l'age" de votre Excel.
pour info: si vous allonger de champ,vous pouvez couvrir plusieurs année"s sans problème

explications pour la formule en colonne J:

=SI(B7="D";SOMME(DECALER(INDIRECT(ADRESSE(LIGNE()-6;9));0;0;7;1));"")
  • la formule s'applique uniquement si B ="D" sinon elle renvoie""

principe de DECALER pour définir un champ:
  • =DECALER(Celle départ;nbr de lignes;nbr de colonne;hauteur du champ; largeur du champ)
  • ADRESSE construit un texte sur le principe:

=ADRESSE(N° de ligne de la feuille;N° de colonne de la feuille)
(vous pouvez essayez par exemple dans une cellule = ADRESSE(1;1) pour voir ce que ça donne à l'affichage)
  • INDIRECT transforme cette adresse texte en adresse Excel
  • LIGNE() renvoie le N° de ligne où se trouve la formule


donc on va chercher la cellule de départ avec ADRESSE(LIGNE()-6;9)
soit donc la colonne I 6 lignes au dessus de la formule
;0;0;7;1) définissent les coordonnées de départ (soit la cellule puisque 0;0; la hauteur soit 7 lignes à partir du départ et une seule colonne de largeur
et bien sur fait la somme de ce champ.


Bonne route

crdlmnt
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020

Merci pour vos explications, j'ai bien compris que la formule est faite pour situer les cellules a calculer
en indiquant les colonnes, - 6 on décale de 6 colonnes vers la gauche, 9 = colonnes.....

super merci beaucoup, je ne sais pas si je serai le refaire....

pour les jours fériés, c'est excel 2007, pouvez-vous essayer de m'expliquer comment nommer un champ

Merci
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 527
Nommer un champ

méthode 1
sélectionner le champ
placer le curseur dans la case adresse à gauche de la barre de formule
effacer l'adresse de la cellule et taper le nom choisi
entrer avec la touche enter

méthode 2
sélectionner le champ
Ruban / Onglet formule / Paragraphe "Noms définis"
"définir un nom"
entrer le nom dans le cadre du haut et OK

Excel n'accepte pas des noms commençant par une valeur numérique, contenant un blanc ou un opérateur (comme - par ex)
conseil: entrer des noms courts: comme jf par exemple pour le champ des jours fériés

.. et n'oubliez pas de bien lister les jours fériés qui correspondent à l'année choisie

crdlmnt
Messages postés
66
Date d'inscription
mardi 22 août 2017
Statut
Membre
Dernière intervention
21 janvier 2020

et voilà, super tout fonctionne, les jours fériés, les MFC, j'ai même crée des colonnes supplémentaires en modifiant vos formules grâce à vos explications,
Merci beaucoup pour votre patience...
je vous souhaite de passer de bonne fête de fin d'année.

Cordialement.
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 527
Pas de quoi
bonne route et au plaisir
crdlmnt