NB.SI entre deux dates [Fermé]

Signaler
-
Messages postés
12938
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 mars 2021
-
Bonjour,

J'aurais besoin d'avoir le nombre de colonne E entre le 01/11/2016 et le 01/04/2017. J'ai également une autre condition.
J'ai essayé la formule: NB.SI.ENS($E$4:$E$41983;">DATEVAL("31/10/2016")";$E$4:$E$41983;"<DATEVAL("1/04/2017")";$BM$2:$BM$41983;CL6)

mais elle ne fonctionne pas. je voulais donc savoir comment on pouvait savoir le NB qui corresponds a ces 3 critères? et plus précisement mon problème c'est avoir une fonction qui puisse regarder les cellules qui correspondent au critère 1 et 2.

Merci par avance,
cordialement,

A voir également:

2 réponses

Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 507
Bonjour,

regarde comme cela

=SOMMEPROD(($E$4:$E$41983>="31/10/2016"*1)*($E$4:$E$41983<="1/04/2017"*1))

et si tu places tes dates critères en cellules exemple G1 et H1
=SOMMEPROD(($E$4:$E$41983>=G1)*($E$4:$E$41983<=H1))


Messages postés
12938
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 mars 2021
2 137
Bonjour à tous

L'écriture correcte de la formule concernant les dates :
=NB.SI.ENS($E$4:$E$41983;">" & DATEVAL("31/10/2016");$E$4:$E$41983;"<" & DATEVAL("1/4/2017");$BM$4:$BM$41983;CL6)
D'autre aprt toutes les plages doivent être de même taille et ta dernière plage $BM$2:$BM$41983 ne correspondait pas

Cdlmnt
Via
Merci beaucoup pour votre réponse!! cela fonctionne pour la fonction NB.SI
maintenant j'aimerais faire une moyenne si avec les memes conditions, et quand je fais :

=MOYENNE.SI.ENS(CH1:CH41983;$E$4:$E$41983;">" & DATEVAL("31/10/2016");$E$4:$E$41983;"<" & DATEVAL("1/4/2017");$BM$4:$BM$41983;CL6)

cela ne fonctionne pas... pourtant j'ai bien des chiffres en CH
Messages postés
12938
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 mars 2021
2 137 > marinev.h
Déjà même problème la taille des plages qui doivent être identiques
Ce n'est pas CH1:CH41983 mais CH4:CH41983
Vois déjà si en corrigeant cela résout le problème; si ce n’est pas le cas poste un exemple de ton fichier sur cjoint.com, fais créer un lien que tu copies et reviens coller ici