Activation ssl

Bonjour,
J'ai acheté un certificat ssl je veux l'appliquer à mon site qu'il devient accessible en https j'ai installer un serveur web apache sous ubuntu serveur et sa marche mais mon problème est comment faire pour appliquer le certificat ssl à mon site je ne sais pas coment faire qui peux m'aider ?

5 réponses

  1. Contributeur
    'lut,
    suffit de rajouter ça dans ton/tes
    <VirtualHost>
    de la config Apache:
    SSLEngine on
    SSLCertificateFile /chemin/vers/le/certficat.crt
    SSLCertificateKeyFile /chemin/vers/la/cleprive.key
    SSLCertificateChainFile /chemin/vers/la/chainedecertifs.crt
    Au passage, si ton certificat SSL n'utilise pas de vérification étendue (EV) ou ne s'applique pas à un domaine en wildcard, tu n'avais pas besoin de payer, il y a Let's Encrypt qui fait très bien l'affaire et ne coûte pas un rond.
    0
    1. Bonjour ElementW mon certificat s'aplique à un domaine le site que je veux l'appliuer est un sous domaine d'un domaine existant et le certificat qu'on m'a donné est un fichier zippé qui se nomme New-Cert.req
      Peux tu etre plus claire concernant la clé privé et la clé publique?
      0
      1. Contributeur
        C'est plutôt à toi d'être plus clair: y'a quoi dans ce fichier? Il contient forcément les 3 éléments (clef publique, privée, et chaîne de signatures), ou alors tu n'as pas eu le bon fichier. Il faut que tu poses ces 3 composantes dans un dossier uniquement accessible par apache et indique leur chemin, c'est tout.
        0
    2. Bonjour ElementW je comprends mieux maintenant donc c'est l ecertificat qu'on m'a donné qui n'est pas bon on m'a donné uniquement le fichier nommé New-Cert.req je vais demander à mon vendeur et au moment de la déclaration du lien du site dans le fichier de configuration de mets tout le lien d'acces comme par exemple le lien du site que je veux l'appliquer est de la sorte 11.23.41.9:8080/oma-sit
      Comment faire?
      0
      1. Contributeur
        Déjà répondu, en supposant que tu utilises Apache, du moins... Il faut juste bien mettre les lignes que j'ai mentionnées dans la section
        <VirtualHost 11.23.41.9:8080>
        . Le certificat s'applique sur tout le domaine, impossible de l'appliquer qu'à un chemin de celui-ci.
        Je remarque que tu as une adresse IP comme "nom de domaine", et signer une IP avec un certificat SSL n'est dans 99% des cas pas accepté par les vendeurs de certificats, bien que possible techniquement.
        0
      2. @ElementWBien compri cette fois ci
        L'adresse ip correspond à un nom de domaine . Je vais enlever cette adresse et mettre le nom domaine à la place . Maintenant je vais demander les certificats et passer à la pratique apres je te reviens et merci pour ta disponiblité
        0
    3. ElementW j'ai fais la configuration mais lorsque j'essaie de redemarrer le service apache2 sa echoue et quand je fais systemctl status apache2.service voila ce que j'obtiens comme message d'erreur

      root@ubuntu:/etc/apache2/sites-available# systemctl status apache2.service
      ● apache2.service - LSB: Apache2 web server
      Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
      Drop-In: /lib/systemd/system/apache2.service.d
      └─apache2-systemd.conf
      Active: failed (Result: exit-code) since Mon 2017-12-04 03:09:43 PST; 10min a
      Docs: man:systemd-sysv-generator(8)
      Process: 3512 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS
      Process: 3792 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILU

      Dec 04 03:09:43 ubuntu apache2[3792]: * The apache2 configtest failed.
      Dec 04 03:09:43 ubuntu apache2[3792]: Output of config test was:
      Dec 04 03:09:43 ubuntu apache2[3792]: AH00526: Syntax error on line 35 of /etc/a
      Dec 04 03:09:43 ubuntu apache2[3792]: Require not allowed here
      Dec 04 03:09:43 ubuntu apache2[3792]: Action 'configtest' failed.
      Dec 04 03:09:43 ubuntu apache2[3792]: The Apache error log may have more informa
      Dec 04 03:09:43 ubuntu systemd[1]: apache2.service: Control process exited, code
      Dec 04 03:09:43 ubuntu systemd[1]: Failed to start LSB: Apache2 web server.
      Dec 04 03:09:43 ubuntu systemd[1]: apache2.service: Unit entered failed state.
      Dec 04 03:09:43 ubuntu systemd[1]: apache2.service: Failed with result 'exit-cod
      lines 1-19/19 (END)

      Peux tu me debloquer stp?
      0
      1. Contributeur
        Peux tu me debloquer stp?
        Pas sans la config du serveur. Un peu de lecture du log ne fait pas de mal pour déterminer d'où vient le problème, et ce serait bien que tu fasses ça avant d’appeler à l'aide.
        0
    4. ElementW

      Voici un peu de resume de ce que j'ai fais

      d'abord j'ai les 3 cles qui se nommentmail_cncas_sn.crt, DigitCertCA.crt et server.key

      le lien vers le site c'est 10.200.0.23:8080/omb-web
      voici le fichier de configuration des hosts

      root@cncas-virtual-machine:/etc/apache2/sites-available# nano 000-default.conf

      <VirtualHost *:443>
      # The ServerName directive sets the request scheme, hostname and port t$
      # the server uses to identify itself. This is used when creating
      # redirection URLs. In the context of virtual hosts, the ServerName
      # specifies what hostname must appear in the request's Host: header to
      # match this virtual host. For the default virtual host (this file) this
      # value is not decisive as it is used as a last resort host regardless.
      # However, you must set it for any further virtual host explicitly.
      ServerName 10.200.0.23:8080/omb-web/

      #ServerAdmin webmaster@localhost
      DocumentRoot /var/www/html/

      # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
      # error, crit, alert, emerg.
      # It is also possible to configure the loglevel for particular
      # modules, e.g.
      #LogLevel info ssl:warn
      ErrorLog ${APACHE_LOG_DIR}/error.log
      CustomLog ${APACHE_LOG_DIR}/access.log combined

      # For most configuration files from conf-available/, which are
      # enabled or disabled at a global level, it is possible to
      # include a line for only one particular virtual host. For example the
      # following line enables the CGI configuration for this host only
      # after it has been globally disabled with "a2disconf".
      #Include conf-available/serve-cgi-bin.conf

      SSLEngine on
      SSLCertificateFile /etc/ssl/certs/mail_cncas_sn.crt
      SSLCertificateKeyFile /etc/ssl/private/server.key
      SSLCertificateChainFile /etc/ssl/certs/DigiCertCA.crt
      SSLVerifyClient none
      </VirtualHost>

      # vim: syntax=apache ts=4 sw=4 sts=4 sr noet

      root@cncas-virtual-machine:/etc/apache2/sites-available# tail -f /var/log/apache2/error.log

      [Tue Dec 05 12:03:00.973563 2017] [ssl:emerg] [pid 30621:tid 3074697792] AH02565: Certificate and private key 10.200.0.23:8080:0 from /etc/ssl/certs/mail_cncas_sn.crt and /etc/ssl/private/server.key do not match
      AH00016: Configuration Failed
      [Tue Dec 05 12:03:12.992419 2017] [ssl:emerg] [pid 30643:tid 3075140160] AH02565: Certificate and private key 10.200.0.23:8080:0 from /etc/ssl/certs/mail_cncas_sn.crt and /etc/ssl/private/server.key do not match
      AH00016: Configuration Failed
      [Tue Dec 05 12:04:42.321037 2017] [ssl:emerg] [pid 30688:tid 3074308672] AH02565: Certificate and private key 10.200.0.23:8080:0 from /etc/ssl/certs/mail_cncas_sn.crt and /etc/ssl/private/server.key do not match
      AH00016: Configuration Failed
      [Tue Dec 05 13:15:04.725069 2017] [ssl:emerg] [pid 31268:tid 3074492992] AH02565: Certificate and private key 10.200.0.23:8080:0 from /etc/ssl/certs/mail_cncas_sn.crt and /etc/ssl/private/keyssl.key do not match
      AH00016: Configuration Failed
      [Tue Dec 05 13:40:18.639162 2017] [ssl:emerg] [pid 31512:tid 3074468416] AH02565: Certificate and private key 10.200.0.23:8080:0 from /etc/ssl/certs/mail_cncas_sn.crt and /etc/ssl/private/server.key do not match
      AH00016: Configuration Failed

      J'ai donné les droits aux fichiers menant vers la cle prive
      root@cncas-virtual-machine:/etc/apache2/sites-available# chmod 400 /etc/ssl/private/server.key

      j'ai copié les 2 certificats DigicertCA.crt et mail_cncas_sn.crt dans /etc/ssl/certs

      Et enfin voici la sortie de la commande apache2ctl -S

      root@cncas-virtual-machine:/etc/apache2/sites-available# apache2ctl -S
      AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
      VirtualHost configuration:
      • :443 10.200.0.23 (/etc/apache2/sites-enabled/000-default.conf:1)

      ServerRoot: "/etc/apache2"
      Main DocumentRoot: "/var/www/html"
      Main ErrorLog: "/var/log/apache2/error.log"
      Mutex watchdog-callback: using_defaults
      Mutex ssl-stapling-refresh: using_defaults
      Mutex ssl-stapling: using_defaults
      Mutex ssl-cache: using_defaults
      Mutex default: dir="/var/lock/apache2" mechanism=fcntl
      PidFile: "/var/run/apache2/apache2.pid"
      Define: DUMP_VHOSTS
      Define: DUMP_RUN_CFG
      User: name="www-data" id=33
      Group: name="www-data" id=33
      root@cncas-virtual-machine:/etc/apache2/sites-available#
      0