Multiplier 2 colonnes sur excel [Résolu/Fermé]

Signaler
-
 kkh -
Bonjour,

je cherche à multiplier A1 par D1 puis A2 par D2 etc jusqu'à A40 par D40 et à obtenir le résultat dans une seule cellule sans recréer une colonne supplémentaire.
Une astuce?
grand merci,
Marie


4 réponses

Messages postés
2066
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
11 août 2020
786
Bonsoir
Si c'est (A1*D1)+A2*D2)+(A...*D...)
Alors
=SOMMEPROD(A1:A40;D1:D40)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57594 internautes nous ont dit merci ce mois-ci

rapide et efficace merci
Messages postés
12481
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
11 août 2020
1 963
Bonjour

=SOMMEPROD((A1:A40)*(D1:D40))

Cdlmnt
Via
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57594 internautes nous ont dit merci ce mois-ci

Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 831
Bonjour amical à yclik et à Via.
Bonjour à toi, Marie.

Ce n'est pas une astuce qui t'a été fournie, mais deux formules, utilisant chacune la fonction SOMMEPROD ...

Elles donnent évidemment le même résultat, à une différence près :
si tu saisis accidentellement un texte à la place d'une valeur numérique,
avec la syntaxe d'yclik =SOMMEPROD(A1:A40;D1:D40) Excel considérera qu'il y a la valeur zéro dans la cellule ;
avec la syntaxe de Via =SOMMEPROD((A1:A40)*(D1:D40)) Excel signalera l'erreur en affichant comme résultat
#VALEUR!


Cordialement.
Bonjour chers aideurs!
Je vous remercie de vos réponses!
Cela fonctionne!