Remplir un tableau a partir de données d'un autre tableau [Fermé]

Signaler
-
Messages postés
25432
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
-
Bonjour,
Je dois remplir la colonne d'un tableau à partir de données d'un autre tableau.
Quelle formule dois-je appliquer ?
Merci


2 réponses

Messages postés
22
Date d'inscription
dimanche 15 octobre 2017
Statut
Membre
Dernière intervention
24 novembre 2017
7
les formules normal je crois puis dans ta sélection tu clic sur l'autre feuille de calcule par exemple et sur les cellules que tu veux prendre en compte. la sélection ressemblera à quelque chose comme Feuille2'=B4:E8
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
25432
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
5 552
Bonjour
tout dépend de la configuration de votre tableau
pour rechercher une valeur A située dans la 1° colonne d'une plage et ressortir une valeur de la énième colonne sur la même ligne:

=RECHERCHEV(valeur A;limites de plage;N° de colonne à ressortir;0)

le N° de colonne à ressortir est le rang de la colonne dans la plage, pas dans la feuille

exemple:
ressortir d'une plage B1:X100, la valeur de la colonne C sur la ligne où se trouve la valeurA inscrite en Z1 dans la colonne B:

=RECHERCHEV(Z1;$B$1:$X$100;2;0)

si elle n'est pas dans la 1° colonne:

=INDEX(limites de plage;EQUIV(valeur A;colonne de recherche;0);N° de range de la colonne à ressortir)

exemple avec la même plage, mais valeur à chercher en colonne D:

=INDEX($B$1:$X$100;EQUIV(1;$D$1:$D$100;0);2)

pour éviter dans tous les cas des affichages d'erreur si la valeur A n'existe pas dans la colonne

à partir d'Excel 2007

=SIERREUR(formule complète);"")

pour être plus précis, il faudrait en savoir plus sur vos données

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!