[Apache2] Mon site ne pointe pas sur le bon répertoire

Résolu
Bonjour,
J'ai loué récemment un VPS chez OVH.
J'ai suivi des tutoriel afin d'y héberger un site.
J'ai donc installé et configuré proftpd et bind9. Tout fonctionne sauf que lorsque j'entre l'adresse de mon site, celui-ci ouvre la page "It's work" d'Apache située sur le chemin suivant : "/var/www/html/index.php". Pourtant j'ai configuré mon Virtual Host afin qu'il pointe sur "/home/xifly/www" :


<VirtualHost *:80>
ServerAdmin xifly@hotmail.fr
ServerName www.xifly.xyz
ServerAlias xifly.xyz
DocumentRoot /home/xifly/www
<Directory />
Options FollowSymLinks
AllowOverride All
</Directory>

<Directory /home/xifly/www>
Options FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>


Si quelqu'un sait d'où cela peut venir ? :)

2 réponses

  1. Salut,
    tu as regardé les logs de apache ?
    au fait,
    apache n'a probablement pas les droits d'accès sur ton home....
    0
    1. Aïe aïe aïe
      J'ai été vérifier les fichier de configuration d'Apache et j'ai juste changé le "var/www/html" que j'ai trouvé en "home/*/www" dans le fichier apache2.conf :
      <Directory /home/*/www>
      Options Indexes FollowSymLinks
      AllowOverride None
      Require all granted
      </Directory>

      Ain si que dans le fichier "/etc/apache2/sites-enabled/000-default.conf" où j'ai changé le :
      DocumentRoot /home/*/www

      Mais désormais plus moyen de restart ou de reload apache ... :/
      J'ai essayé de remettre ce qu'il y avait avant mais rien n'y change.

      Ça affiche l'erreur suivante :
      Reloading apache2 configuration (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details

      Et lorsque j'entre "journalctl -xn", j'obtient :
      -- Logs begin at Sat 2017-11-04 16:00:07 CET, end at Thu 2017-11-09 12:14:21 CET. --
      Nov 09 12:13:31 xiflyserver dhclient[385]: dhclient.c:2243: Failed to send 300 byte long packet over fallback interface.
      Nov 09 12:13:46 xiflyserver dhclient[385]: DHCPREQUEST on eth0 to 213.32.64.1 port 67
      Nov 09 12:13:46 xiflyserver dhclient[385]: send_packet: Operation not permitted
      Nov 09 12:13:46 xiflyserver dhclient[385]: dhclient.c:2243: Failed to send 300 byte long packet over fallback interface.
      Nov 09 12:14:03 xiflyserver dhclient[385]: DHCPREQUEST on eth0 to 213.32.64.1 port 67
      Nov 09 12:14:03 xiflyserver dhclient[385]: send_packet: Operation not permitted
      Nov 09 12:14:03 xiflyserver dhclient[385]: dhclient.c:2243: Failed to send 300 byte long packet over fallback interface.
      Nov 09 12:14:21 xiflyserver dhclient[385]: DHCPREQUEST on eth0 to 213.32.64.1 port 67
      Nov 09 12:14:21 xiflyserver dhclient[385]: send_packet: Operation not permitted
      Nov 09 12:14:21 xiflyserver dhclient[385]: dhclient.c:2243: Failed to send 300 byte long packet over fallback interface.

      J'ai également essayé de désinstaller et réinstaller Apache.
      Je suis perdu >.<
      0
    2. Ok, il y a eu une coupure de courant chez OVH ce matin. C'est peut être dû à ça.
      0
  2. Modérateur
    Salut,

    Le domaine précisé pointe bien vers l'IP du serveur avec une entrée DNS de type "A" ?

    De mon côté, j'ai une adresse qui pointe dans le vide, donc... ça sent déjà les soucis à un niveau ;-)

    Apache a été redémarré après la mise à jour du vhost ? Le vhost a bien été activé (par
    a2ensite
    ) ?
    0
    1. Oui, le fichier /etc/bind/db.mondomaine semble correcte. J'ai pu tester en mettant un site test dans le dossier /var/www/html et cela marchait.
      Mon site est hébergé sur l'adresse http://www.alexandre-joron.xyz/ c'est pour ça.
      Mais désormais il pointe dans le vide.
      0