Formule excel pour calcul de la nouvelle indemnite de licencieme [Fermé]

Signaler
Messages postés
1
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
8 novembre 2017
-
Messages postés
126
Date d'inscription
jeudi 9 décembre 2010
Statut
Membre
Dernière intervention
21 février 2019
-
Bonjour,

Je n'arrive pas à faire une formule sur excel pour le nouveau calcul de l'indemnité légale de licenciement .
Lorsque le salarié est en année plaine, la formule fonctionne bien mais lorsque l'année est incomplète la formule ne fonctionne plus.
Sachant que la formule de calcul est:

1/4 de mois de salaire par année d'ancienneté pour les 10 premières années +1/4 de mois de salaire * x/12

1/3 de mois de salaire par année d'ancienneté à partir de la 11ème année + 1/3 de mois de salaire * x/12 (x étant le nombre de mois).

j'ai fait la formule suivante: =(((salaire*années<=10)/4)+((salaire*mois)/(4/12))+((salaire*années > 10ans ) /3)+(salaire*mois)/(3/12)).


Merci pour l'aide que vous pourrez m'apporter

2 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 238
Bonjour,

Avec ton salaire en A2 et la date d'embauche en B2, je te propose cette formule qui doit pouvoir être simplifiée d'ailleurs.
=MIN(DATEDIF(B2;AUJOURDHUI();"m");120)*0,25*A2+SI(DATEDIF(B2;AUJOURDHUI();"m")>120;(DATEDIF(B2;AUJOURDHUI();"m")-120)*0,33*A2;0)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
23663
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 novembre 2020
6 483
Bonjour,

une simplification en effet :
=A2*(MIN(120;DATEDIF(B2;AUJOURDHUI();"m"))/4+MAX(0;DATEDIF(B2;AUJOURDHUI();"m")-120)/3)

attention, le *0.33 au lieu de /3 désavantage le salarié.
eric
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 238
Salut Éric,

Bien vu, cela supprime le test et c'est plus net.
Messages postés
126
Date d'inscription
jeudi 9 décembre 2010
Statut
Membre
Dernière intervention
21 février 2019
18
Bonjour Stel27, gbinforme, eriiic,

Selon les articles 39 et 40 de l’ordonnance n° 2017-1387 et de ce que j'en ai compris.

Il y a 3 régimes depuis septembre 2017 d'indemnité légale de licenciement.

Concernant le licenciement pour motif personnel, économique ou inaptitude d’origine non professionnelle et impossibilité de reclassement : Il y a un plancher de 8 mois et un plafond de 240 mois.

D'où cette formule avec date en "A2" et salaire moyen en "B2".
Résultat en "C2":
=SI(DATEDIF($A2;AUJOURDHUI();"m")>240;0,25*B2*MIN(10;DATEDIF($A2;AUJOURDHUI();"y"))+1/3*B2*(DATEDIF($A2;AUJOURDHUI();"y")-MIN(10;DATEDIF($A2;AUJOURDHUI();"y")));SI(ET(DATEDIF($A2;AUJOURDHUI();"y")<1;DATEDIF($A2;AUJOURDHUI();"ym")<8);0;SI(DATEDIF(A2;AUJOURDHUI();"y")>10;0,25*B2*MIN(10;DATEDIF($A2;AUJOURDHUI();"y"))+1/3*B2*(DATEDIF($A2;AUJOURDHUI();"y")-MIN(10;DATEDIF($A2;AUJOURDHUI();"y")))+0,25*B2*DATEDIF($A2;AUJOURDHUI();"ym")/12;0,25*B2*DATEDIF($A2;AUJOURDHUI();"y")+0,25*B2*DATEDIF($A2;AUJOURDHUI();"ym")/12)))

J'imagine que vous allez hurler en voyant cette formule à rallonge, pourtant elle me semble juste et je ne doute pas quelle puisse être raccourcie.

Voir les différents cas de figure dans le fichier joint.
http://www.cjoint.com/c/GKjl4goA0Eu

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 238
Bonsoir,

J'imagine que vous allez hurler en voyant cette formule à rallonge,... et je ne doute pas quelle puisse être raccourcie

Tu as bien imaginé ! Ta formule roman ne sert pas à grand chose car celle d'Éric corrigée au désavantage du salarié que j'avais très enrichi donne exactement le même résultat :
=B2*(MIN(120;DATEDIF(A2;AUJOURDHUI();"m"))/4+MAX(0;DATEDIF(A2;AUJOURDHUI();"m")-120)/3)/12

Pour quoi faire simple si l'on passer beaucoup de temps à complexifier ! ;-)

Si tu vérifies les exemples donnés par service-public tu verras que la formule simple est plus juste pour le second.
Messages postés
126
Date d'inscription
jeudi 9 décembre 2010
Statut
Membre
Dernière intervention
21 février 2019
18 >
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020

Re gbinforme,

Pour quoi faire simple si l'on passer beaucoup de temps à complexifier ! ;-)

Parce que je n'ai pas ton talent ;~) toutefois tu ne tiens pas compte du plancher de 8 mois et du plafond de 240 mois.

Cela donnerait ceci en "C2" en tenant compte de ta modif:
=SI(DATEDIF(A2;AUJOURDHUI();"m")<8;0;SI(DATEDIF(A2;AUJOURDHUI();"m")>240;0,25*B2*MIN(10;DATEDIF($A2;AUJOURDHUI();"y"))+1/3*B2*(DATEDIF($A2;AUJOURDHUI();"y")-MIN(10;DATEDIF($A2;AUJOURDHUI();"y")));B2*(MIN(120;DATEDIF(A2;AUJOURDHUI();"m"))/4+MAX(0;DATEDIF(A2;AUJOURDHUI();"m")-120)/3)/12))

Penses-tu pouvoir raccourcir plus ?

Cordialement.