Compteur excel

Résolu/Fermé
Messages postés
4
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
9 novembre 2017
-
Messages postés
24295
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
-
Bonjour à tous,

J'ai besoin de votre aide svp.
j'ai des données dans une colonne qui se répètent. je souhaiterais créer une nouvelle colonne qui met des 1 uniquement la première fois qu'une valeur apparaît (si elle apparaît une seconde fois, que la cellule soit vide): ce serait une colonne compteur pour un tcd...
j'ai essayé la fonction frequence avec le si mais ca ne fonctionne pas... j'ai 5000 lignes je ne peux pas le faire manuellement.
je suis complètement bloquée...
Merci pour votre qide

2 réponses

Messages postés
3427
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
28 janvier 2022
501
Bonjour,

en b2
=si(a2<>a3;1;"")

Cdlmnt
Messages postés
55462
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 janvier 2022
17 230
... et si tes données ne sont pas triées dans la colonne A, utilise en B3 la formule
=SI(NB.SI(A$2:A3;A3)=1;1;"") à recopier vers le bas.
Messages postés
4
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
9 novembre 2017

Merci Djidji et Raymond pour vos réponses rapides! ça marche bien même si j'ai 2 ou 3 répétitions encore( sur 3000 lignes je peux pas me plaindre!). je re-verifie avec un tcd et je rectifie a la mano. je crois que le pb c'est que je peux avoir des données qui se suivent et se répètent jusqu'a 4 ou 5 fois....
Messages postés
3427
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
28 janvier 2022
501 >
Messages postés
4
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
9 novembre 2017

Bonjour ,
bonjour Raymond

Joins un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné.
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
Messages postés
55462
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 janvier 2022
17 230 >
Messages postés
4
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
9 novembre 2017

BEEcas,
Je te signale que la formule =SI(NB.SI(A$2:A3;A3)=1;1;"") fait exactement ça !
Il ne peut pas y avoir de répétition ...
Messages postés
4
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
9 novembre 2017

https://www.cjoint.com/c/GKirKHriZze

Le lien met du temps à se mettre en bleu j'espère que vous pourrez voir l'exemple.
Donc en A j'ai des familles de produits, en B des codes et en C des coloris (un code à plusieurs coloris d'où la repetition des codes).je souhaiterais avoir en D, des 1 uniquement lorsqu'un code apparaît pour la 1ere fois et rien pour les répétitions. Ce tableau va me servir pour avoir le tcd que j'ai schématisé à côté.le but est de déterminer le nombre de code par famille...
Désolée c'est brouillon mais je travaille de mon portable...
Merci encore.
Messages postés
24295
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
7 040
Bonjour,

=SI(EQUIV(A3;A:A;0)=LIGNE();1;"") 

eric
Messages postés
4
Date d'inscription
mercredi 8 novembre 2017
Statut
Membre
Dernière intervention
9 novembre 2017

Merci Éric ça marche!!!!
Et merci pour les citations !!!!je mets en résolu...
Merci à tous...
Messages postés
24295
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
7 040
La proposition de raymond sans doute aussi. Tu aurais pu tester correctement avant