Copier une ligne en fonction d'une cellule [Fermé]

Signaler
Messages postés
1
Date d'inscription
lundi 6 novembre 2017
Statut
Membre
Dernière intervention
6 novembre 2017
-
Messages postés
12758
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 octobre 2020
-
Bonjour,

Pouvez vous me dire comment faire pour copier une ligne en fonction d'une cellule sur une autre feuille.

Sur l'exemple ici, le choix de la cellule serait en fonction de la colonne B ( épaisseur)
J'aimerais que si on sélectionne 6 (B11), toute la ligne 11 s'écrive.

MErci d'avance.

1 réponse

Messages postés
12758
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 octobre 2020
2 041
Bonsoir peterpepin

Utilise RECHERCHEV pour chaque élément d'une colonne à renvoyer

ex : =RECHERCHEV(6;$B$6:$Q$16;2;0)
va chercher 6 en colonne B et renvoyer la valeur de la 2eme colonne du tableau B6:Q12 située sur la même ligne soit la valeur en col C (le 0 en fin de formule demande une correspondance exacte)
Dans la cellule suivante tu veux que la formule renvoie la valeur en colonne D sur la même ligne que 6 en B donc la formule va être :
=RECHERCHEV(6;$B$6:$Q$16;3;0)
etc

Pour plus de facilité tu peux au départ nommer la plage Bl:Q13 ( selectionner plage - clic droit Nommer la plage) par exemple montableau et utiliser ensuite ce nom dans la formule :
=RECHERCHEV(6;montableau;2;0)

Enfin si tu veux changer la valeur à chercher, tu entres cette valeur par ex en A1 et dans la formule tu indiques la référence à cette cellule
=RECHERCHEV($A$1;montableau;2;0)
ainsi chaque fois que tu modifieras la valeur en A1 le résultat dans la cellule de la formule s'adaptera

Cdlmnt
Via
"L'imagination est plus importante que le savoir."    A. Einstein