Conversion formule en VBA.. [Résolu/Fermé]

Signaler
Messages postés
468
Date d'inscription
jeudi 27 mars 2014
Statut
Membre
Dernière intervention
8 mars 2020
-
Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
-
Bonjour chers tous
une fois de plus je reviens solliciter votre aide.
Je souhaiterai convertir cette formule en VBA pour l'appliquer sur toute une colonne.
=SI($A3>DATE(C$1;12;31);"absent";SI($B3="";"present";SI(C$1<=ANNEE($B3);"present";"absent"))

Merci de votre aide
je vous lie le fichier
http://www.cjoint.com/c/GIfiBBTQxqN
Cordialement




4 réponses

Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 852
Bonjour

http://www.cjoint.com/c/GIfnGHaCrDB

Cdlmnt
Messages postés
8128
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
24 juin 2020
1 431
Bonjour,

Pour recopier la formule depuis C2 vers C1000 :
With Worksheets("Feuil1")
  .Range("C2").AutoFill Destination:=.Range("C2:C1000")
End With 

Ou pour l'écrire directement :
Worksheets("Feuil1").Range("C2:C1000").FormulaR1C1 = _
  "=IF(RC1>DATE(R1C,12,31),""absent"",IF(RC2="""",""present""," & _
  "IF(R1C<=YEAR(RC2),""present"",""absent"")))"

Messages postés
468
Date d'inscription
jeudi 27 mars 2014
Statut
Membre
Dernière intervention
8 mars 2020
32
Bonjour

C'est tout ce qu'il me fallait Ça frôle la perfection mon cher ccm81.
Reste plus qu'a l'adapter a mon travail.
Merci Patrice , mais mon souhait n'était pas de "coller" les formules par VBA.

Bien merci à vous deux .

Bien cordialement
Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 852
De rien

Si tu as beaucoup de lignes, tu peux ajouter un
Application.ScreenUpdating = False
en début de code (après les déclarations de variables)

Si c'est fini, peux tu mettre le sujet à résolu (en dessous du titre de ton premier message)

Cdlmnt