EXCEL2013 - Chercher une cellule vide ? [Résolu/Fermé]

Signaler
Messages postés
18
Date d'inscription
mardi 18 juillet 2017
Statut
Membre
Dernière intervention
26 août 2017
-
Messages postés
25306
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2020
-
Bonjour,

Je souhaite dans une cellule quelconque chercher la première cellule vide d'une colonne et la noter ; A1 ou B26 etc... Comment faire ?

Rémi.

1 réponse

Messages postés
25306
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2020
5 483
Bonjour

cette formule en matricielle, à adapter pour trouver la 1° cellule vide d'une colonne, même si d'autres cellule vides suivent:
de A1 à A1000
=ADRESSE(PETITE.VALEUR(SI(A1:A1000="";LIGNE(A1:A1000));1);1)

Matricielle: à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées. Elle s'affiche automatiquement entre accolades dans la barre de formule

si il n'y a pas de cellule vide intercalée dans la colonne, ça fonctionne aussi mais ça peut être plus simple:
en partant de A1

=ADRESSE(NB.VAL(A:A);1)
entrée au clavier normalement
sachant dans les deux cas que le ;1) correspond à la colonne A / si B: ;2) etc...

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60990 internautes nous ont dit merci ce mois-ci

Messages postés
18
Date d'inscription
mardi 18 juillet 2017
Statut
Membre
Dernière intervention
26 août 2017

Merci la première formule fonctionne, mais comment l'adapter pour la colonne B ?
Messages postés
25306
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2020
5 483
Logiquement s'il s'agit de ne traiter que la colonne B, vous pouvez écrire
=ADRESSE(PETITE.VALEUR(SI(B1:B1000="";LIGNE(1:1000));1);2)

mais si vous voulez trouver la 1° cellule vide dans les deux colonnes ensemble, essayez:

=SI(PETITE.VALEUR(SI(A1:A1000="";LIGNE(1:1000));1)<PETITE.VALEUR(SI(B1:B1000="";LIGNE(1:1000));1);ADRESSE(PETITE.VALEUR(SI(A1:A1000="";LIGNE(1:1000));1);1);ADRESSE(PETITE.VALEUR(SI(B1:B1000="";LIGNE(1:1000));1);2))


toujours entrées en matricielle

crdlmnt