Comparaison de cellules et récupérer valeur d'une cellule [Résolu/Fermé]

Signaler
-
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
-
Bonjour,

le titre n'est pas très clair je pense.. voilà mon problème, dans mon classeur j'ai 2 feuilles, la première "suivi" la seconde "commentaires".

Feuille "suivi" :
A;B;C;D
Nom;Prénom;Date dernier commentaire;Dernier commentaire

Feuille "commentaires" :
A;B;C;D
Nom;Prénom;Date du jour;Commentaire

L'idée serait dans "suivi" de récupérer le dernier commentaire pour une personne.

J'ai réussi à trouver pour récupérer la dernière date d'un commentaire pour une personne
Formule dans "suivi" en C2:
=MAX(SI((commentaires!$A$2:$A$5000=$A2)*(commentaires!$B$2:$B$5000=$B2);commentaires!$D$2:$D$5000))

Seulement voilà pour récupérer le dernier commentaire pour une personne je bloque.

Quelqu'un aurait-il une idée ou une piste à me donner?

Merci

3 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Bonjour

en ligne, toujours en matricielle:

=SIERREUR(INDEX(Commentaires!$D$2:$D$5000;EQUIV(A2&C2;Commentaires!$A$2:$A$5000&Commentaires!$C$2:$C$5000;0));"")

si vous risquez d'avoir des noms identiques, rajouter le prénom dans les codes:
=SIERREUR(INDEX(Commentaires!$D$2:$D$5000;EQUIV(A2&B2&C2;Commentaires!$A$2:$A$5000&Comme,taires!$B$2:$B$5000&Commentaires!$C$2:$C$5000;0));"")

attention aux signes et à l'entrée en matricielle

tout cela suppose que chaque personne ne fait qu'un seul commentaires par jour

crdlmnt




Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Bonjour

en ligne, toujours en matricielle:

=SIERREUR(INDEX(Commentaires!$D$2:$D$5000;EQUIV(A2&C2;Commentaires!$A$2:$A$5000&Commentaires!$C$2:$C$5000;0));"")

si vous risquez d'avoir des noms identiques, rajouter le prénom dans les codes:
=SIERREUR(INDEX(Commentaires!$D$2:$D$5000;EQUIV(A2&B2&C2;Commentaires!$A$2:$A$5000&Commentaires!$B$2:$B$5000&Commentaires!$C$2:$C$5000;0));"")

attention aux signes et à l'entrée en matricielle

tout cela suppose que chaque personne ne fait qu'un seul commentaire par jour

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
Bonjour Vaucluse,

Merci beaucoup pour ta réponse très clair, cela fonctionne!

Effectivement cela implique pas plus d'un commentaire par jour ce qui sera mon cas, cependant je pense que pour résoudre ce problème il suffit d'ajouter l'heure dans les cellules date ?

Encore merci pour ton temps.

Cordialement
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
effectivement, avec l'heure, ça permettra de sélectionner, sauf si le commentateur "cause" plus d'une fois par minute en tapant à la vitesse grand V (ce qui n'est pas mon cas :-(( !)
Mais ce serait peut être exagéré!! :-))
Bonne route
crdlmnt