Valeur si avec plusieurs vrais

[Fermé]
Signaler
Messages postés
2
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
14 août 2017
-
 françois -
Bonjour,

J'aimerais savoir comment appliquer une formule. J'ai fait un onglet avec le nom de différentes villes et leur code postal.

J'aimerais que la case B1 inscrive le bon code postal selon la valeur texte en A1.

Je ne sais pas comment appliquer la formule SI avec plusieurs valeurs et plusieurs vrais.

Ci-joint screenshot de mon fichier et de son data.

https://img-19.ccm2.net/HxNhz2ZZfsUZmABDC6n3Ts2xV78=/3053fff1549a4c7ea5599f219fabeb86/ccm-ugc/excel.jpg

2 réponses

Bonjour Cynthia,

Je te propose cette formule, à mettre en B1 et à copier vers le bas :
=SI(A1<>"";SIERREUR(RECHERCHEV(A1;DATA!A:B;2;0);"");"")

Cordialement
 
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Bonsoir
la formule est exacte,François, mais le début est superflu puisque si A est vide,elle se met en erreur
=SIERREUR(RECHERCHEV(A1;DATA!A:B;2;0);"")
Mais d'accord, ça ne change pas grand chose en fait
. Le but de mon message est surtout de signaler a Cynthia que la formule ne fonctionnera que si contient un nom exacte de la base de données, ce qui n'est pas le cas dans son exemple, car il faudra choisir entre LES MECHINS et LES MECHINE
D'où mon conseil: placer un menu déroulant en A de la feuille d'édition pour éviter les erreurs de frappe

crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
2
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
14 août 2017

Merci!

J'essaie de mettre les valeurs en anglais puisque mon environnement est en anglais. Je suis convaincue que ça va marcher! Merci énormément :)
>
Messages postés
2
Date d'inscription
lundi 14 août 2017
Statut
Membre
Dernière intervention
14 août 2017

 
Bonsoir Cynthia,

En anglais, je crois que c'est : =IFERROR(VLOOK(A1;DATA!A:B;2;0);"")

Si ton problème est réglé, merci d'aller en haut de page pour cliquer
sur le lien « Marquer comme résolu » : le titre du sujet devient vert.

Cordialement
 
 
Bonsoir Vaucluse,

Oui, je l'avais bien vu (et c'est ce que j'avais fait au départ), mais :
a) J'ai trouvé dommage que ça se mette en erreur juste pour une cellule vide.
b) Avec le test supplémentaire devant, je pense que c'est plus rapide car ça
    n'a pas besoin d'évaluer SIERREUR(), ni RECHERCHEV().

Je suis entièrement d'accord avec ton conseil du menu déroulant !

Cordialement