Nombre de fois ou deux valeurs se suivent dans une colonne [Résolu/Fermé]

Signaler
-
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
-
Bonjour,

Je cherche une formule pour connaître le nombre de fois ou deux valeurs se suivent dans une colonne. Les valeurs sont sous forme de texte.

Merci !

2 réponses

Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Bonjour
pour une liste qui commence en A2 pour finir en A101 à condition qu'il n'y ait pas e cellules vides en fin de liste, ni de cellules vides qui se suivent (sinon elles seront comptées)

=SOMMEPROD((A2:A100=A3:A101)*1)

compte deux si elle trouve trois fois à la suite la même valeur, etc...

attention au décalage de une cellule entre les deux champs

crdlmnt

Merci pour votre réponse.

Et comment faire quand les deux valeurs qu'on cherche ne sont pas identiques.
Par exemple le nombre de fois que B suit A dans la colonne:
A
B
C
A
C
A
B

Je voudrais trouver le nombre 2. Merci !
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Re

=SOMMEPROD((A1:A6="A")*(A2:A7="B"))

à ajuster sur la hauteur du champ
crdlmnt
>
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020

Merci beaucoup !!
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt