Totalise le nombre fois avec 2 criteres [Résolu/Fermé]

Signaler
-
 samuel -
Bonjour,
Juin
Z AD
jeu 01 H
Ven 02 N
sam 03 N
dim 04 N
lun 05 H (jour ferie)

sur mon tableau dans la colonne Z les dates et la colonne AD les donnes
j'aimerai pourvoir totalise le jour ferie et la lettre "H" dans le mois de juin.




sur un tableau j'ai une colonne avec les dates (p7:p37) et une autre colonne (t7:t37) avec les données
J'aimerai pouvoir totalise un jours férié et la lettre "H"

et ceci pour tous les mois de l’année.
J’espère que vous m'avez compris
Merci a vous
Samuel




8 réponses

Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Bonjour,

pas très clair comme explications, d'après ce que je comprends, tu as deux colonnes mensuelles dans une tu as jeu 01 ou simplement jeu et dans l'autre 01 H ou simplement H
Bonjour,

Janvier
la date se trouve dans la colonne A (Jeu 01)
Les données dans la colonne B
en fin de colonne je voudrais totalise le nombre de jour ferie ou les donnes sont la lettre H

jeu 01 H
Ven 02 N
sam 03 N
dim 04 N

résultat fin Colonne B le total est de (1)
désolé j’espère que cette exemple sera plus clair.
Merci
je reviens,

la formule que j'aimerai trouver

si la colonne a1 (jeu 01)= a un jour férié et que la colonne b1= "H" on trouve 1 si non 0.

j"'espère que cela peux vous aide a mieux comprendre.
Merci
Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Re,

alors
=NB.SI(B1:B50;"H")
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 395
Bonjour

essayez avec ça, à adapter
date en A de A2 à A100
code H en B2:B100
liste des jours fériés en Z1:Z10

=SOMMEPROD((NB.SI($Z$1:$Z$10;$A$2:$A$100))*($B$2:$B$100="H"))


utilisez bien les N° de ligne pour limiter les champs (pas de A:A, B:B ) sinon la formule est plutôt lourde

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Re bonjour,

C'est vraiment super, exactement ce que je voulais.
un grand merci a vous.
Cordialement
Samuel
Messages postés
17159
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 août 2020
4 167
Re,

tu n'as pas précisé quelle formule a fait ton bonheur, le principal est d'avoir atteint ton objectif.
Je passe le statut de la discussion en résolu
Bonjour,

Désolè j'ai n'est pas précisé quelle était la formule qui me convient a mon tableau.
C’est Vaucluse avec la formule :
=SOMMEPROD((NB.SI($Z$1:$Z$10;$A$2:$A$100))*($B$2:$B$100="H")) .
je le remercie a lui et a vous tous.
Cordialement.
Samuel