Commande net use en .bat impossible a executer avec password [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
9 mars 2020
-
Messages postés
12635
Date d'inscription
lundi 2 mars 2009
Statut
Contributeur
Dernière intervention
2 juillet 2020
-
Bonjour, je souhaiterais exécuter une commande net use avec authentification et password. Mon password commence par le signe < et fini par le signe >. Hors le problème sur Notepad quand je fais la commande: Net use G \\computername\sharename /USER:name password , il n'intègre pas les signes dans le password. Du coup la commande ne fonctionne pas car il affiche <password> et les signes sup et inf sont séparés du mot de passe. Comment dire a notepad que les signes ne sont pas une option ou je ne sais quoi pour qu'il puisse être intégrer.
Désolé si je m'explique mal, je débute avec les scripts. Merci de votre aide.

2 réponses

Messages postés
12635
Date d'inscription
lundi 2 mars 2009
Statut
Contributeur
Dernière intervention
2 juillet 2020
3 318
Bonjour,

Il faut insérer un caractère d'échappement avant les caractères <>, sous DOS ce caractère est ^

Si ton mot de passe est : >toto#57ccm<
Alors il faudra écrire : ^>toto#57ccm^<
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65005 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
9 mars 2020

Merci je viens d'essayer mais ça ne fonctionne pas. J'utilise notepad++ et il m'affiche toujours ^<password^> avec les signes qui sont de différentes couleurs que le password.
Messages postés
12635
Date d'inscription
lundi 2 mars 2009
Statut
Contributeur
Dernière intervention
2 juillet 2020
3 318
Désolé je ne vois pas d'autres solutions.