Help - fonction : recherche

Résolu/Fermé
LeLutin68
Messages postés
12
Date d'inscription
mercredi 15 avril 2015
Statut
Membre
Dernière intervention
16 février 2022
- 27 avril 2017 à 11:33
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 27 avril 2017 à 14:02
Bonjour à tous,

je vous demande de l'aide pour mettre en œuvre une formule pour effectuer une recherche.

Objectif : recherche un article dans une plage de donnée et renvoyer son prix.

Plage de données des articles : A1:C3
Prix : D1:D3

Je connais la fonction rechercheV mais ici la difficulté est que la plage comporte plusieurs colonnes ….

Merci pour votre aide :)

Le Lutin

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
27 avril 2017 à 12:37
Bonjour
essayez plutôt avec INDEX / EQUIV

si votre article cherché est en Z1 ( à adapter)

=INDEX($D$1:$D$3;EQUIV(Z1;SI(NB.SI($A$1:$A$3;Z1);$A$1:$A$3;SI(NB.SI($B$1:$B$3;Z1);$B$1:$B$3;$C$1:$C$3));0))
crdlmnt
0
LeLutin68
Messages postés
12
Date d'inscription
mercredi 15 avril 2015
Statut
Membre
Dernière intervention
16 février 2022

27 avril 2017 à 12:57
Bonjour Vaucluse,
En fait j'ai environ 30 colonnes (avec dedans des articles), et une colonne avec les prix, j'aimerai donc faire une recherche dans la plage des 30 colonnes pour identifier l'article et renvoyer son prix ....
merci pour l'aide
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256 > LeLutin68
Messages postés
12
Date d'inscription
mercredi 15 avril 2015
Statut
Membre
Dernière intervention
16 février 2022

27 avril 2017 à 13:07
Et les 30 articles sur la même ligne ont le même prix?

alors les colonnes de A à AD et les listes de ligne 2 à ligne 100
les prix de AE2 à AE 100

l'article cherché en feuil2!A2
la formule en B2:

=SOMMEPROD((Feuil1!$A$2:$AD$100=A2)*(Feuil1!$AE$2:$AE$100))

vu le "poids" de ce type de formule, limitez bien les plages au nombre de lignes utiles

crdlmnt
0
LeLutin68
Messages postés
12
Date d'inscription
mercredi 15 avril 2015
Statut
Membre
Dernière intervention
16 février 2022

27 avril 2017 à 13:23
Merci Vaucluse, donc je dois utiliser un sommeprod ?

Les articles vont de la colonne / lignes W8 à BI1424
Les prix se situent dans la colonne BJ

Effectivement tous les articles présent sur une ligne ont le même prix, et théoriquement on ne les retrouve pas dans une autre ligne. (il s'agit de retrouver le prix de vente du produit fini, en recherchant un article qui le compose).
0
LeLutin68
Messages postés
12
Date d'inscription
mercredi 15 avril 2015
Statut
Membre
Dernière intervention
16 février 2022

27 avril 2017 à 13:26
Parfait Vaucluse ca fonctionne :)
0
LeLutin68
Messages postés
12
Date d'inscription
mercredi 15 avril 2015
Statut
Membre
Dernière intervention
16 février 2022

27 avril 2017 à 13:27
=SOMMEPROD((BaseArticles!W8:BI1414=3055096)*(BaseArticles!BJ8:BJ1414))
0