[Excel] Msg d'erreur ouverture document xls

[Fermé]
Signaler
Messages postés
1440
Date d'inscription
jeudi 3 octobre 2002
Statut
Contributeur
Dernière intervention
5 janvier 2013
-
 Pierre -
Bonjour à toutes et à tous.

Ma config : Win XP familial, et Office XP qui va avec.

Sur mon bureau, un racourcis vers une feuille excel que nous appellerons Feuille.xls, et qui se trouve tout simplement dans C:\ ... \Mes Documents\
- Si je lance Excel par le menu Démarrer, puis que je fais Fichier ... Ouvrir ... et que je vais rechercher la feuille dans le bon répertoire, no problemo !
- Si j'utilise le racourcis du bureau, ou que je double-cliques sur le fichier lui-même dans l'explorateur => excel s'ouvre, puis apparait un popup me signalant qu'un fichier nommé Feuille.xls est déjà ouvert, et qu'excel ne peut pas ouvrir 2 fichiers portant le même nom provenant de répertoires différents ...

Opérations déjà effectuées :
- J'ai fait une recherche sur le disque, pas d'autre fichier de ce nom en vue.
- J'ai exploré la base de registre, et supprimé les entrées correspondant à ce fichier => Pas d'amélioration.
- J'ai essayé avec un autre fichier excel => Même message d'erreur.
Donc ça vient non pas de cette feuille, mais bel et bien d'excel.

Si quelqu'un a une idée, je lui en serait bien reconnaissant.
Euh ... sauf si c'est pour me dire de ré-installer Excel, bien sûr ;o)

Merci d'avance ...

  (:•Þ   Pitu
A voir également:

13 réponses

Messages postés
13531
Date d'inscription
jeudi 9 janvier 2003
Statut
Contributeur
Dernière intervention
16 mai 2014
529
Salut,

voici le nom que l'on pourrai donner à ce type d'erreur:

Double clic non fonctionnel pour l'ouverture

Sur certains ordinateurs, pour ouvrir un document excel je dois d'abord ouvrir xcel et ensuite le document . L'ouverture par double clic envoie un essage indiquant l'abscence d'un composant.

Dans l'explorateur, va dans le menu Affichage, Options des dossiers puis nglet Types de fichiers. Recherche ensuite dans la liste Feuille de calcul S Excel, et vérifie à quoi est associée l'extension xls. Si ce n'est pas xcel à toi de le corriger via le bouton modifier...Bon courage !

*********************

DEMARRER -> EXECUTER -> taper "c:\program files\ .....\office\excel.exe"
/regserver
Il faut bien mettre les guillemets et taper le chemin exact (en remplaçant les point !!!) vers excel.exe, puis fermer les guillemets, un espace, et

/regserver

**********************
Sinon au niveau d'Excel2000 on peut recréer les liens avec le système
en renommant la clé Excel du Registre en "Excel.old" par exemple. voici le chemin dans le Registre :

Poste de travail\ Hkey_Current_User\Software\Microsoft\Office\9.0\Excel

Cette adresse est valable pour Excel2000, Attention pour l'utilisateur non averti du Registre!


Voici une réponse qui a été faite pour des fichiers pdf mais le problème est
similaire avec excel :

Si le chemin du fichier contient un répertoire dont
le nom contient un espace, comme "Program files" c'est peut-être parce qu'il y
a eu le bazar (suite à quoi, ça, c'est le grand mystère!!)
dans la ligne de commande d'association des .pdf, stockée dans la base de registres!
A savoir que les guillemets se sont pris des vacances !

Généralement, quand on veut associer les fichiers à extension ".xyz" (de
type "xyzfile") à l'application "machin.exe", cela est réalisé dans la
BDR par présence de la clef :
HKEY_CLASSES_ROOT\xyzfile\shell\open\command
dont la valeur par défaut sera :
"x:\.........\machin.exe" "%1"

%1 est un paramètre formel, dont le contenu sera le nom du fichier
pointé dans l'explorer, et passé à l'application.
%1 signifie "1er paramètre" (tout comme %2 = 2ème paramètre,..., comme
dansun fichier batch)

Or quand on passe un ou plusieurs paramètres, dans une ligne de
commande, à un exécutable, l'espace est LE caractère SEPARATEUR!
(c'est valable dans presque TOUS les processeurs de commandes de TOUS
les systèmes d'exploitation)

Donc si le nom du fichier contient des espaces, c'est comme si on avait
passé PLUSIEURS paramètres!
P.ex., si le nom de fichier est :
q:\mes documents\documentations diverses\manuel d'utilisation.pdf
et si ce nom n'est pas encadré par des guillemets, c'est comme si on
avait transmis à l'application :
paramètre 1 : q:\mes
paramètre 2 : documents\documentations
paramètre 3 : diverses\manuel
paramètre 4 : d'utilisation.pdf

A moins que l'appli soit super-intelligente (;+))) et ait
l'idée de concaténer ces 4 paramètres en 1 seul, la plupart du temps elle
essaiera (en vain!!) d'ouvrir 4 fichiers, à savoir
"q:\mes","documents\documentations",..., qui évidemment n'existent pas, d'où
une superbe injurebox !! ;+)

En encadrant le paramètre formel %1 par des guillemets, le nom de
fichier va donc être lui-même encadré par ces guillemets, et alors transmis en UNE
SEULE FOIS à l'appli, qui pourra l'ouvrir normalement!

Il faut donc que tu rétablisses la situation :
- soit depuis l'explorer de Windows
- soit en allant bidouiller dans la BDR

1) manip "Explorer"
================
(NB: je suis sous Windows 2000, donc les libellés peuvent différer chez toi)
Menu "Outils"/"Options des dossiers" Onglet "types de fichiers"

Rechercher alors le type :
"PDF Document Adobe Acrobat" (ou équivalent)
Bouton "Avancée"

Dans la boite de dialogue qui s'ouvre alors :
Sélectionner "Open"
Bouton "Modifier"

Dans la boite de dialogue qui s'ouvre alors :
Contrôler/Modifier le contenu du champ :
"Application utilisée pour exécuter cette action :"
P.ex., chez moi je trouve :
"D:\Program Files\Adobe\Acrobat 4.0\Acrobat\Acrobat.exe"
"%1" Ajouter les guillemets autour de %1 s'ils sont absents

Vérifier aussi le champ (s'il existe et si la case "Utiliser DDE" est
cochée)
"Message DDE"
P.ex., chez moi je trouve :
[FileOpenEx("%1")]
Ajouter les guillemets autour de %1 s'ils sont absents

Puis boutons "OK", "OK",
"Fermer"

2) Manip "Base de registres"
=========================
Lancer
"Regedit" (menu "Démarrer" / "Exécuter")

Chercher la clef :

HKEY_CLASSES_ROOT\.pdf
Examiner le contenu de l'entrée par défaut (dans le panneau de droite)
P.ex., chez moi je trouve :

AcroExch.Document
(j'utilise Acrobat complet, et non pas Acrobat Reader. Le
libellé peut donc être différent chez toi)

Examiner alors la clef :

HKEY_CLASSES_ROOT\AcroExch.Document\shell\open\command
(à adapter, en fonction du contenu de HKEY_CLASSES_ROOT\.pdf)
Contrôler le contenu de la valeur par défaut
P.ex., chez moi je trouve :
"D:\Program Files\Adobe\Acrobat 4.0\Acrobat\Acrobat.exe" "%1"
Ajouter les guillemets autour de %1 s'ils sont absents

Faire de même avec la clef :

HKEY_CLASSES_ROOT\AcroExch.Document\shell\open\ddeexec
Contrôler le contenu de la valeur par défaut
P.ex., chez moi je trouve :

[FileOpenEx("%1")]

Ajouter les guillemets autour de %1 s'ils sont absents



Je ne sais pas si cela va résoudre ton problème, mais c'est déjà un début...

A++

:-))


Linux is like sex, it's better when it's free... ;)))
C'est ceux qui s'en servent pas qui en disent du mal...
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Bonjour,

J'ai eu le même message d'erreur (document déjà ouvert) sous Windows 2000 et XP en essayant d'ouvrir, à partir de l'explorateur des documents en EXCEL 97 dont le nom ou le répertoire contenait des espaces.

La solution était la suivante :
- Dans l'explorateur Windows sélectionner Outils /Options de dossier puis l'onglet Type de Fichiers.
- Choisir Excel XLS.
- Cliquer sur Avancé choisir l'action Open.
- Indiquer "C:\Program Files\Microsoft Office\Office\excel.exe" "%1" et décocher la case Utiliser DDE.
- Valider le tout et tester.

Cordialement.
Mille mercis !!!!! aprés une demi journée à tout essayer ta solution fonctionne parfaitement :-)
merci pour cette solution !!!
Ca marche !!! :o) MERCI !!!
cette solution est la bonne merci ;)
Je précise que la partie importante c'est le "%1" j'ai remplacé dans mon registre (regedit) %1 par "%1" et ça passe
Messages postés
3635
Date d'inscription
jeudi 24 avril 2003
Statut
Contributeur
Dernière intervention
11 septembre 2005
306
Je pense quand même que foobar47 est dans le vrai : panneau de configuration, options des dossiers, onglet types de fichiers, XLS, avancé, choisis Open et vérifie les paramètres :
Application utilisée : "C:\Program Files\Microsoft Office\Office\EXCEL.EXE" /e

Message DDE : [open("%1")]
Application : EXCEL
Rubrique : system


-= Fu Xuen =-
moi j ai eu le même PB

en fait pour resoudre il suffit de rajouter des guillemés
de chaque coté de %1

dans option des dossiers

type e fichiers Xls
Modifier

et dans Application utilisé
il y avait
"C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" %1
j ai mis
"C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" "%1"
ca marche
Bonjour,
Merci pour cette solution Olivier. Avec les guillemets tout fonctionne.
Grand merci à toi Olivier,
j'avais ce problème depuis ... plusieurs années ! très agacant, je ne sais pourquoi cela est apparu mais à chaque double-clic sur un fichier xls depuis l'explorer (windows xp familial sp3), j'avais ce message.
En ajoutant le guillemets ... c'est parfait.
Merci.
merci car moi je vien de reparer mon trouble moi aussi

Merci aussi, trop cool cette soluce !

Richard
Messages postés
23
Date d'inscription
samedi 16 avril 2005
Statut
Membre
Dernière intervention
24 octobre 2008
2
Bonjour à tous,

En faisant des recherches, je suis tombé sur cet ancien post.

Mon problème est un peu différent mais avec le même message d'erreur.

Dans un fichier, j'ai créé une barre d'outils personnalisée contenant plusieurs boutons.

Je lance Excel en double-cliquant sur mon fichier "Test essai.xls", il se lance, pas de problème.

Mais lorsque je clique sur n'importe lequel de mes boutons, j'obtiens ce message d'erreur.
Par contre, si je vais dans le menu "macro" et que je lance une de mes macros directement, je n'ai pas l'erreur.

Je suppose donc que cela vient de ma barre d'outil.
Est-ce encore ce foutu fichier Excel.xlb à incriminer?
Si oui, je veux bien le supprimer et le remplacer mais comment prévenir que cela n'arrive une deuxième fois?

En vous remerciant grandement de votre aide.

Aries No Shion
bonjour bravo pour la solution !!!

J'ai eut le même soucis avec un office 97 par contre à présent lorsque j'ouvre un fichier word cela me met un message :

"ouvrir "document" tel qu'il était lors du dernier enregistrement?"

Qu'en pensant vous ???

merci d'avance
Messages postés
1440
Date d'inscription
jeudi 3 octobre 2002
Statut
Contributeur
Dernière intervention
5 janvier 2013
121
Merci de cette réponse, mais le message d'erreur n'est pas relatif à un composant d'excel qui n'aurait pas été trouvé, et pour lequel ta réponse aurait parfaitement convenu.
Là, c'est plutôt "un fichier nommé feuille.xls est déjà ouvert. Excel ne peut pas ouvrir 2 fois le même nom de fichier dans des répertoires différents".
Bon, c'est pas exactement le message, mais c'est ce qu'il veut dire.
Ce que j'ai oublié de préciser, c'est que lorsque je cliques sur le bouton OK du popup, j'édite bien mon fichier sans aucun pb.
Ce n'est donc pas bloquant, mais simplement agaçant d'avoir systématiquement à faire "OK" sur ce message d'erreur.
Et puis, un msg d'erreur de MicroSoft, à force, ça gratouille, non ?

  (:•Þ   Pitu
Messages postés
179
Date d'inscription
lundi 15 juillet 2002
Statut
Membre
Dernière intervention
29 juin 2006
23
Bonjour Pitu,

Trouvé sur http://www.excelabo.net/xl/plantages.htm#dejaouvert

========
La première chose à vérifier c'est si le classeur n'aurait pas été
enregistré après avoir été masqué.
Pour le savoir, tu vérifies dans le menu Fenêtre si l'option Afficher est
disponible, si c'est le cas, il y a un classeur masqué ouvert et il te
suffira d'enregistrer ton classeur dans cet état pour que le problème soit résolu.
Autres possibilités :
- Le fichier a été masqué et enregistré dans cet état, puis placé dans le
répertoire Program Files\Microsoft Office\Office\Xlouvrir (97) ou XlStart (2000)
- Le fichier a été masqué et enregistré dans cet état, et ton raccourci vers
Excel pointe sur le nom du fichier
- Une autre instance d'excel n'est-elle pas active ?
Je n'ai peut-être pas fait le tour, mais c'est une piste !
Papou
========

Monique
Elle est pas belle la vie ?
Messages postés
1440
Date d'inscription
jeudi 3 octobre 2002
Statut
Contributeur
Dernière intervention
5 janvier 2013
121 >
Messages postés
179
Date d'inscription
lundi 15 juillet 2002
Statut
Membre
Dernière intervention
29 juin 2006

Je te remercie de ton aide, Monique.
Je regarderai ça ce soir, mais j'ai peur du résultat, car ce phénomène n'est pas lié à un document, mais à toutes les feuilles excel que j'ai.
a+

  (:•Þ   Pitu
En fait, pour moi sur les .doc et .xls, je n'avais aucun des guillemets mentionnés plus haut. J'ai donc mis 4 guillemets comme décrits ci-dessus.

pb résolu

merci
Salut tous !
J'avais également le même pb depuis longtemps, je n'avais aucun guillemet, j'en ai rajouté 4 comme oliv78, depuis, tout est OK. XP et office 97 pro.
merci jcw et Olivier
frajer1
Je vous remercie pour les indications que vs donnez sur le forum,en effet je ne suis pas un PRO de l'informatique,mais grace à vs le dépannage a été possible tout seule.(PROBLEME OUVERTURE DE DOSSIER EXCEL)

"C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" "%1"


CA MARCHE


MERCI
un grand merci pour cette réponse
LOL sa fait 2 ans et plus ce message et le monde écrivent dessus a chaque année xD
pas comprendre toi ???
Eh bien c'est à mon tour d'avoir ce problème !!!

Quelle est l'astuce avec Windows 7 ??? Je n'ai pas les mêmes options de dossiers :/
http://answers.microsoft.com/fr-fr/office/forum/office_2013_release-excel/les-fichiers-excel-ne-souvre-pas-par-double-click/6d5cda42-8583-46d6-8388-566a9fd40272?page=2


Je suis sous Windows 10, mais la solution doit être très proche !