Somme avec les fonctions Index/Equiv entre deux dates

Résolu/Fermé
LucaDiti - 26 mars 2017 à 20:28
 LucaDiti - 28 mars 2017 à 22:45
Bonjour,

Je vous contacte car je pense que la communauté pourrait m'apporter un grand soutien pour ma demande. En effet, la voici:

J'ai un tableau contenant 3 types de mouvements du stock de l'entreprise (achats, ventes, endommagés) et sont aussi classés par date de fin de mois (31 janvier, 28 février, 31 mars, etc.).

Le but serait, entre deux dates, de savoir combien il y a eu de mouvements d'achats pour le produit A pour le stock 1.

J'ai fait le tour pendant quelque temps sur internet mais je n'ai rien trouvé. J'espérait alors avoir une petite réponse dans le coin.

Merci infiniment pour votre temps et une excellente fin de journée à vous.

Luca

Lien du fichier: http://www.cjoint.com/c/GCAsBKJTpc5

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
26 mars 2017 à 20:57
Bonsoir

pour répondre à votre tableau (qui ne spécifie pas le stock, en B18
=SOMMEPROD((B1:J1>=B15)*(B1:J1<=B16)*(B2:J2=B17)*(B3:J8))

pour spécifier aussi le stock, si vous l'affichez en B18,
formule en B19:
=SOMMEPROD((B1:J1>=B15)*(B1:J1<=B16)*(B2:J2=B17)*(A3:A8=B18)*(B3:J8))

crdlmnt
1
Bonsoir,

Je vous remercie infiniment pour votre réponse. ça a super bien fonctionné, navré pour l'oubli de la case "stock", que vous avez bien réussi à faire marcher avec SOMMEPROD, que je connaissais pas. Cela pourra m'ouvrir pas mal de nouveaux horizons :).

Excellente soirée! :)

Luca
0