Formule Excel plus grand que X mais plus petit que Y

Résolu/Fermé
colins12
Messages postés
2
Date d'inscription
samedi 25 mars 2017
Statut
Membre
Dernière intervention
26 mars 2017
- 25 mars 2017 à 21:27
colins12
Messages postés
2
Date d'inscription
samedi 25 mars 2017
Statut
Membre
Dernière intervention
26 mars 2017
- 26 mars 2017 à 09:05
Bjr à tous,

Je souhaite faire une formule qui dit que si la valeur B1 est plus petite que 1, alors la case B2 est égale à 1. Mais si B1 est plus grande que 1, alors la case B2 est égale à B1. Ensuite si B1 est plus grande que 1.1, alors la case B2 est égale à 1.1. Mais si elle est plus petite que 1.1, alors la case B2 est égale à B1.

EN GROS :

La valeur B1 doit être : 1<B1<1.1
mais si plus petit que 1 c'est 1 et si plus grand que 1.1 c'est 1.1...

MERCI DE M'AIDER

1 réponse

JvDo
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
850
25 mars 2017 à 23:01
Bonsoir,

Essaye =MAX(1;MIN(B1;1,1))

Cordialement
0
Raymond PENTIER
Messages postés
56468
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 août 2022
17 192
26 mars 2017 à 04:00
Bonjour colins2.

La formule de JvDo est un modèle de raisonnement logique et de concision d'écriture. Elle remplace avantageusement la formule classique qui serait
=SI(B1<=1;1;SI(B1<=1,1;B1;1,1))
ou la formule équivalente
=SI(B1>1,1;1,1;SI(B1>1;B1;1))
0
colins12
Messages postés
2
Date d'inscription
samedi 25 mars 2017
Statut
Membre
Dernière intervention
26 mars 2017

26 mars 2017 à 09:05
Ah bin c'est parfait merci beaucoup !!
0