Comment mettre "0" si la valeur de la cellule est négative?

Fermé
valphi63 Messages postés 8 Date d'inscription samedi 20 août 2016 Statut Membre Dernière intervention 6 juillet 2017 - 30 mars 2017 à 15:28
valphi63 Messages postés 8 Date d'inscription samedi 20 août 2016 Statut Membre Dernière intervention 6 juillet 2017 - 30 mars 2017 à 22:33
j'aimerais pouvoir ajouter une formule à une cellule. Si j'ai créé une formule dont le résultat devient négatif, comment compléter la formule de manière à ce que la cellule affiche "0" au lieu du nombre en négatif?
A voir également:

3 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 274
30 mars 2017 à 15:33
Bonjour

=SI(formule=0;0;formule)

ou plus court:

=MAX(formule;0)

crdlmnt
9
valphi63 Messages postés 8 Date d'inscription samedi 20 août 2016 Statut Membre Dernière intervention 6 juillet 2017
30 mars 2017 à 20:10
bonjour Vaucluse. alors votre réponse n'a pas solutionné mon problème car je n'étais sûrement pas assez précis dans ma question.
Voici ce que j'ai fait:
En cellule D21; j'ai mis la formule =B19-C19 selon cette formule j'ai un résultat positif. Maintenant; je tente de créer une formule dans la cellule C21 qui va comme suit: =C19-B19 et j'obtiens nécessairement une valeur négative. Or, j'aimerais dans ma formule dont la valeur est négative pouvoir faire en sorte que la valeur devienne visible dans la cellule C21 avec "0".
merci de vos précieux conseils et bonne journée,
0
yclik Messages postés 2975 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 1 octobre 2022 1 353 > valphi63 Messages postés 8 Date d'inscription samedi 20 août 2016 Statut Membre Dernière intervention 6 juillet 2017
30 mars 2017 à 20:18
bonsoir
en C21
=SI(C19-B19<0;0;"")
6