Comment mettre "0" si la valeur de la cellule est négative? [Fermé]

Signaler
Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017
-
Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017
-
j'aimerais pouvoir ajouter une formule à une cellule. Si j'ai créé une formule dont le résultat devient négatif, comment compléter la formule de manière à ce que la cellule affiche "0" au lieu du nombre en négatif?

3 réponses

Messages postés
25419
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2020
5 546
re
si vous ne voulez que des résultats positifs sinon 0, c'est bien ce que vous propose:
=MAX(C19-B19;0)
vous donnera un résultat si positif, sinon 0

et si le résultat est forcément négatif, autant entrer 0 au clavier une fois pour toutes plutôt que de placer une formule!

crdlmnt
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017

bien, mais ça risque de changer en positif avec le temps. Alors j'y vais avec la formule de =MAX(C19-B19;0).

je découvre Excel et je suis complètement ébahis de ce qu'on peut faire avec ce logiciel!!!
merci,
Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017

J'aimerais parfaire mes connaissances avec ce logiciel. Quelle lecture me conseilleriez-vous?

merci à tous! ;o)
Messages postés
25419
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2020
5 546
Bonjour

=SI(formule=0;0;formule)

ou plus court:

=MAX(formule;0)

crdlmnt
Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017

bonjour Vaucluse. alors votre réponse n'a pas solutionné mon problème car je n'étais sûrement pas assez précis dans ma question.
Voici ce que j'ai fait:
En cellule D21; j'ai mis la formule =B19-C19 selon cette formule j'ai un résultat positif. Maintenant; je tente de créer une formule dans la cellule C21 qui va comme suit: =C19-B19 et j'obtiens nécessairement une valeur négative. Or, j'aimerais dans ma formule dont la valeur est négative pouvoir faire en sorte que la valeur devienne visible dans la cellule C21 avec "0".
merci de vos précieux conseils et bonne journée,
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
857 >
Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017

bonsoir
en C21
=SI(C19-B19<0;0;"")
Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
60
Bonjour ,

merci , svp ?

Idem que ici : https://forums.commentcamarche.net/forum/affich-33830831-bluetooth-et-pc

Au revoir ?

Nos seules limites sont celles que nous nous imposons nous-même.
La politesse et un merci ne tuent pas. Il existe un bouton pour "Résolu" pour confirmer que     votre problème n'en est plus un. Fahora
Messages postés
8
Date d'inscription
samedi 20 août 2016
Statut
Membre
Dernière intervention
6 juillet 2017

Bonjour Fahora, c'est avec grand regret que m’aperçois que je ne communiquais pas avec un robot et vous m'en voyez désolé. Je ne suis pas un connaisseur de forums comme vous venez de le constater. Maintenant que j'ai réparé l'erreur, je vous souhaite une excellente journée ;o)