Définir une lettre étant un chiffre (x=0) [Résolu/Fermé]

Signaler
-
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
-
Bonjour,

Sur Excel 2016 sur Pc, Est-ce que c'est possible que lorsque j'écris la lettre ''x'' le logiciel prenne en considération que sa valeur est zéro?

Par exemple, j'ai une formule qui additionne bien des chiffres d'un programme d'entraînement, mais quand il y a un mouvement très dynamique, j'aimerais mettre un ''x'' au lieu d'un ''0''. Mais la formule rentre la lettre x et donc la rend invalide.

Merci :)

4 réponses

Messages postés
61
Date d'inscription
mercredi 29 juin 2016
Statut
Membre
Dernière intervention
6 juillet 2017
78
sur quel logiciel ?

Excel 2016 su PC!
Messages postés
61
Date d'inscription
mercredi 29 juin 2016
Statut
Membre
Dernière intervention
6 juillet 2017
78
ça va être galère : il faut définir la constante X dans une case, et signaler à excel que désormais X=0. Mais si ça marche dans les programmes informatiques, je doute que ça fonctionne dans un tableur... Désolé !
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
842
Bonjour,

essaye
=SOMME.SI.ENS(B5:B11;B5:B11;"<>""x""")


j'ai supposé que ta zone de données était en B5:B11

cordialement

Merci beaucoup pour vos réponses, j'ai trouvé une solution simple:

1. Aller dans mise en forme conditionnelle
2. Nouvelle règle
3. Appliquer une mise en forme uniquement aux cellules qui contiennent
4. égale à: =0
5. Changer la mise en forme pour ''x''
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
842
Bonjour,

tu peux te passer de MFC pour afficher un "x" pour les valeurs nulles :
tu vas dans format de nombre personnalisé et tu choisis Standard;;"x"

cordialement