Formule si à 4 conditions. [Résolu/Fermé]

Signaler
Messages postés
127
Date d'inscription
samedi 14 février 2009
Statut
Membre
Dernière intervention
20 octobre 2019
-
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
-
Bonjour,

J'aurais besoin d'aide pour finaliser un tableau pour lequel il faudrait utiliser une formule à 4 conditions.
Ci joint le fichier, ce sera plus simple.....

Merci à l'avance .
Jody

https://www.cjoint.com/c/GAEmTLPLlLo

5 réponses

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Bonjour
en D2:
=SI(C2="";"";SI(C2<=10;1;SI(C2<=50;2;SI(C2<=100;3;4))))
crdlmnt
Messages postés
127
Date d'inscription
samedi 14 février 2009
Statut
Membre
Dernière intervention
20 octobre 2019
1
MERCI !!!!!
Messages postés
17372
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 juin 2021
4 640
Bonjour,

en D2 tu colles cette formule, puis tu l'incrémentes vers le bas
=SI(C2>100;4;SI(C2>50;3;SI(C2>10;2;1)))

et s'il faut tester la cellule vide
=SI(C2>100;4;SI(C2>50;3;SI(C2>10;2;SI(C2<>"";1;""))))

tu peux également prendre le calcul inverse
=SI(C2<=10;1;SI(C2<=50;2;SI(C2<=100;3;SI(C2<=150;4;""))))
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Messages postés
127
Date d'inscription
samedi 14 février 2009
Statut
Membre
Dernière intervention
20 octobre 2019
1
Merci à toi.

Jody.
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
16 062
Salut.

=SI(C:C<11;1;SI(C:C<51;2;SI(C:C<101;3;4)))
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
16 062
Ah ! Le temps de rédiger et de valider, il y a déjà 2 autres réponses ...
Heureusement, les 3 formules sont équivalentes, et laissent le choix à JODY55.
Mes amitiés à Vaucluse et Mike-31 !
Messages postés
127
Date d'inscription
samedi 14 février 2009
Statut
Membre
Dernière intervention
20 octobre 2019
1 >
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021

Merci à toi.
Jody
Messages postés
127
Date d'inscription
samedi 14 février 2009
Statut
Membre
Dernière intervention
20 octobre 2019
1
Merci les COPAINS.
c'est SUPER RAPIDE je suis très content.
Bonne journée à vous trois
Jody
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
16 062
... et, juste pour le fun =>
créer le tableau :
___|__A _|__B__
14 | 1 | 0
15 | 11 | 1
16 | 51 | 2
17 | 101 | 3
18 | 151 | 4
et saisir en D:D la formule
=RECHERCHEV(C:C;$A$14:$B$18;2;1)+1