Mettre le nom d'un onglet dans une formule de calcul

Résolu/Fermé
mijean94
Messages postés
394
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
8 novembre 2021
- 16 janv. 2017 à 21:06
mijean94
Messages postés
394
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
8 novembre 2021
- 16 janv. 2017 à 22:19
Bonjour,

J’ai des onglets dans mon classeur qui ont comme noms des années de 2005 à 2016 par exemple.

Dans un onglet, bilan, je fais des calculs, par exemple là sur l’onglet 2015 :

=SOMMEPROD(('2015'!$D$3:$D$215>DATEVAL($C$3))*('2015'!$H$3:$H$215=E6)*('2015'!$G$3:$G$215=F5)*('2015'!$I$3:$I$215))

Ma question:

Y a-t-il une solution pour mettre dans une cellule de mon onglet bilan le nom de l’onglet à prendre en compte dans le fonction ?

Merci pour vos aide.

Bien cordialement

2 réponses

mijean94
Messages postés
394
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
8 novembre 2021
9
16 janv. 2017 à 22:17
Bonjour,

J'ai trouvé la solution :

remplacer,
'2015'!$D$3:$D$215
par,
(INDIRECT("'" & E3 & "'!$D$3:$D$215"))

avec le nom dans la cellule E3

Bien cordialement
3