Fonction SI et arrondir une valeur

[Résolu/Fermé]
Signaler
Messages postés
4
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
7 septembre 2017
-
Messages postés
4
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
7 septembre 2017
-
Bonjour,
Je suis sur Excel 2010 et rencontre 2 difficultés :

1) J'ai une formule dans une colonne qui amène à un résultat à virgule.
Comment faire pour que ce nombre s'arrondisse à l'unité ?
Soit :
- inférieur si 0,01 à 0,49
- supérieur si 0,50 à 0,99
???

2) Dans une autre page (appelée "calculs"), j'ai 2 colonnes :

- en A = nombre de 1 à 150
- en B = une indemnisation correspondante
Dans une autre page, j'ai une colonne (A) qui contient le nombre de km qu'une personne a parcouru (ex : 5).
Et je souhaiterais, dans une autre colonne (B), insérer une formule qui irait chercher la valeur correspondant dans la feuille "calculs" et la multiplierait par le chiffre de la colonne A (5 dans mon exemple).
En clair, si quelqu'un fait 5 km, obtenir 8,8 dans la colonne B (soit 5 x 1,76)

Je ne sais pas si c'est clair...
Pouvez-vous m'aider?

Grand merci

5 réponses

Messages postés
3444
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 septembre 2021
980
Bonjour

Puisque notre ami veux que le nombre soit arrondi je mettrais plutôt cette formule en colonne B de la seconde feuille

=ARRONDI(RECHERCHEV(A1;Calculs!A1:B150;2)*A1;0)

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
20
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
21 octobre 2020
1
La formule que tu cherche est :

=RECHERCHEV(A1;Feuil2!A3:B10;2;0)*8


Si tes 5 km sont dans la cellule A1 de la Feuil1 et ton tableau dans la Feuil2 entre A3 et B10.

J'ai mis *8 mais ça peut très bien être *C4 ....

J'espère t'avoir aidé
Messages postés
20
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
21 octobre 2020
1
Pour l'arrondi de la cellule A1 tu peux utiliser :

 =ARRONDI(A1;0)


Tu es obligé d'avoir ta valeur dans une cellule différente.

Sauf si elle est issue d'un calcul alors tu peux mettre :

=ARRONDI([Calcul];0)
Messages postés
4
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
7 septembre 2017

Merci TeTo25
Pour l'arrondi ça fonctionne super bien, génial!

Par contre, pour la formule, je n'y parviens pas :-(
Il y aurait trop d'arguments dans ma formule (ou est-ce moi qui l'ai mal rédigé?).

Voici un visu de ce que j'essaye de faire :



Dans la colonne I3 de la feuille "octobre", je souhaiterais qu'apparaisse 1,76 (info qui se trouve dans la colonne B7 de la feuille "calculs").

Dans la colonne I4 de la feuille "octobre", je souhaiterais qu'apparaisse 2,33 (info qui se trouve dans la colonne B12 de la feuille "calculs").

etc.

Est-ce un peu plus clair?

Encore merci à toi
Messages postés
3444
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 septembre 2021
980
Tu as oublié le V de rechercheV dans ta formule ; d'où l'erreur signalée

Cordialement
Messages postés
4
Date d'inscription
vendredi 13 janvier 2017
Statut
Membre
Dernière intervention
7 septembre 2017

ouiii ça fonctionne, super.
Merciiii