Fonction SI excel avec 3 conditions et des dates [Fermé]

Signaler
-
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
-
Bonjour,

j'aimerais trouver une formule pour 3 conditions mais qui sont des dates et je n'y arrive pas : est-ce seulement possible ?
Voici ce que je veux :

Si (ma cellule qui est une date) est supérieur à aujourd'hui + 1,2 ou 3 ans = A
Si (ma cellule qui est une date) est supérieur à aujourd'hui + 4 ans = B
Si (ma cellule qui est une date) est supérieur à aujourd'hui + 5 ans = C

merci de m'aider... j'essaie mais je ne trouve pas la solution, mes formules sont incohérentes.

3 réponses

Messages postés
32042
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
8 avril 2021
3 380
Bonjour,

Le nombre de jours dans une année n'étant pas toujours fixes (années bissextiles...)
un truc du genre devrait aller :

=SI(L1<DATE( ANNEE(MAINTENANT()) +3;MOIS(MAINTENANT());JOUR(MAINTENANT()));A1;SI(L1<DATE( ANNEE(MAINTENANT()) +4;MOIS(MAINTENANT());JOUR(MAINTENANT()));B1;SI(L1<DATE( ANNEE(MAINTENANT()) +5;MOIS(MAINTENANT());JOUR(MAINTENANT()));C1;"-")))


oiu l'inverse :


<code>
=SI(L1>DATE( ANNEE(MAINTENANT()) +5;MOIS(MAINTENANT());JOUR(MAINTENANT()));C1;SI(L1>DATE( ANNEE(MAINTENANT()) +4;MOIS(MAINTENANT());JOUR(MAINTENANT()));B1;SI(L1<DATE( ANNEE(MAINTENANT()) +1;MOIS(MAINTENANT());JOUR(MAINTENANT()));A1;"-")))

</code>

Cordialement, 
Jordane                                                                 
Messages postés
5541
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 avril 2021
591
Ou encore ça

Bonjour Min

Essayer ceci

=SI(A1="";"";SI(A1<=DATE(ANNEE(AUJOURDHUI())+3;MOIS(AUJOURDHUI());JOUR(AUJOURDHUI()));"A";SI(A1<=DATE(ANNEE(AUJOURDHUI())+4;MOIS(AUJOURDHUI());JOUR(AUJOURDHUI()));"B";"C")))
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
Bonsoir

et pour ne pas trop user le clavier:

=SI(A1="";"";SI(A>MOIS.DECALER(AUJOURDHUI();60);"A";SI(A1>MOIS.DECALER(AUJOURDHUI();48);"B";"C")))

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
12984
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 avril 2021
2 167
Bonjour

Essaie quelque chose comme :
=SI(A2>AUJOURDHUI()+365*5;"C";SI(A2>AUJOURDHUI()+365*4;"B";"A"))

Cdlmnt
Via