Chercher Valeur selon deux conditions

Fermé
sormick - 29 déc. 2016 à 06:53
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 - 29 déc. 2016 à 11:09
Bonjour,

j'ai un tableau Excel comme ceci:

Colonne A Colonne B Colonne C
20/12/2016 sandrine tache1
20/12/2016 patrick tache6
21/12/2016 beatrice tache3
21/12/2016 julien tache1
21/12/2016 patrick tache4
25/12/2016 patrick tache5
25/12/2016 sandrine tache4
25/12/2016 beatrice tache2
25/12/2016 beatrice tache3
25/12/2016 beatrice tache6

Je voudrais savoir s'il existe une formule Excel qui me permette d'afficher une tache dans la colonne C selon la date.
Par Exemple je souhaiterais qu'il m'affiche qu'à la date du 25/12/2016 qu'il aille me chercher la tache4




A voir également:

2 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 398
Modifié par Vaucluse le 29/12/2016 à 08:28
Bonjour

... qu'il aille me chercher la tache 4
d'accord, mais vous voulez ressortir quoi, et le placer où?
à vous lire

en attendant plus, avec des suppositions:
pour un champ de ligne 1 à ligne 21 pour l'exemple:
si vous cherchez ce que fait sandrine à une date précise

en E1 la date/ en E2 le nom / F2 cette formule:
=INDEX($C$1:$C$21;SOMMEPROD(($A$1:$A$21=$E$1)*($B$1:$B$21=E2)*(LIGNE($A$1:$A$21))))

si vous cherchez qui fait la tache à la même date
en E3 la tache / en F3 cette formule:
=INDEX($B$1:$B$21;SOMMEPROD(($A$1:$A$21=$E$1)*($C$1:$C$21=E3)*(LIGNE($A$1:$A$21))))

notez :
  • que les champs démarrent en ligne 1 pour éviter des corrections de résultat du code SOMMEPROD(qui renvoie le de N° ligne de la feuille où se trouve les valeurs)
  • que ces formules sont assez lourdes et qu'il est recommandé de limiter les champs à la stricte hauteur utile


à vous lire si besoin

crdlmnt


crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Bonjour,

Je souhaiterais faire ressortir la Tâche uniquement par rapport à la date.
S'il y a plusieurs fois la même tâche à la même date je souhaiterais qu'il m'affiche la première tâche.
Désolé c'est pas évident à exdpliquer
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 398
Modifié par Vaucluse le 29/12/2016 à 11:17
ce n'est pas évident à comprendre non plus, surtout quel est le rapport entre votre dernier message et le titre de votre fil, qui évoque une recherche double
Si vous voulez simplement afficher ce que contient C à la 1° ligne de la date en A, il n'y a pas deux valeurs à chercher:

avec une date en D1, en E1:
=RECHERCHEV(D1;A:C;3;0)

si ça ne convient pas, déposez un modèle (réel ou bidon, mais conforme à l'original) avec quelques explications sur:
https://www.cjoint.com/
créez le line sur le site et revenez le coller ici
crdlmnt
0