Formule Somme.si.ens : Comparer 2 Colonne [Résolu/Fermé]

Signaler
Messages postés
342
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
5 novembre 2020
-
Messages postés
342
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
5 novembre 2020
-
Bonjour,

j'ai un tableau dynamique.
j'aimerais ajouter certaines cellules de la ligne C,
si je retrouve les noms contenus dans la ligne B
dans une colonne AA par exemple

je pensais utiliser la formule somme.si.ens

mais sans succès.

Auriez vous une idée ?

Par avance merci




1 réponse

Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
Bonjour

on ne voit pas très bien ce que SOMME.SI.ENS vient faire ici. En fait on ne voit rien du tout.. vous parlez de ligne A et B qui sont en principe, des entêtes de colonnes et ensuite c'est le flou
Vous pouvez si possible déposer un fichier avec explications sur:
https://www.cjoint.com/
et revenir ici coller le lien que vous aurez créé sur le site
On y verra plus clair

à vous lire

crdlmnt
Messages postés
342
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
5 novembre 2020
1
Bonsoir

Voici le lien, j ai mis un fichier exemple en espérant que ça sera plus clair

http://www.cjoint.com/c/FLCrogWm1QK

Cdt
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
re
pas sur d'avoir compris, mais pour avoir la somme de la colonne dont le titre est en N2 (à tirer sur la hauteur des codes en N):

=SOMMEPROD(($C$1:$J$1=N2)*($C$2:$J$5))

C2:J5 à adapter bien sur à la hauteur utile (ou même plus) mais SOMMEPROD nécessite des limites colonnes et lignes (pas de C:J mais $C$2:$J$1000 par exemple)

revenez si ce n'est pas ça, mais réexpliquez alors, par exemple en donnant les adresses des cellules à sommer selon N2 et le résultat attendu

crdlmnt
Messages postés
342
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
5 novembre 2020
1 >
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020

Bonjour,

en fait, je souhaite que la somme s'effectue en
B3
qu'elle ajoute C3, F3,I3
uniquement si les lettres A en C1
D en F1
et G en I1

sont présentes dans la colonne N soit 13544.89
si je retire A de la colonne N j'arrive à 0

En espérant avoir été plus précis
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
Bonjour

pas facile à comprendre non plus

essayez celle ci sur chaque ligne de votre tableau, je suppose à partir de B2

=SOMMEPROD((NB.SI($N$2:$N$4;$C$1:$J$1))*(C2:J2))

à tirer sur la hauteur pour avoir sur chaque ligne, la somme de C à J pour les colonnes qui contiennent les lettres du champ N2:N4 en C1:J1, ceci quelque soit la position des lettres "titres" entre C1 et J1

et si vous remplacez C2:J2 par C2:J5, vous avez le cumul de tout le tableau dans les mêmes conditions

revenez si ça ne convient pas

crdlmnt
Messages postés
342
Date d'inscription
mardi 19 octobre 2010
Statut
Membre
Dernière intervention
5 novembre 2020
1 >
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020

Bonjour

je viens d'essayer c'est exactement ça

merci infiniment et désolé pour la clarté de mes explications