[Excel VBA]Pb SUMIF en VBA [Fermé]

Signaler
Messages postés
17
Date d'inscription
mercredi 8 août 2007
Statut
Membre
Dernière intervention
20 août 2007
-
 néné -
Bonjour

je chercher à faire une somme conditionnelle en prenant en compte un interval de dates, je m'explique :

mon tableau est tout simple: 1ere colonne des dates, 2nd colonne des valeurs associées aux dates.

Je dois faire en sorte que sur la Feuil1, en entrant deux dates (ex:01/01/2006 et 31/01/2006, en gros le mois de janvier), on puisse avoir la somme des valeurs correspondantes au mois de janvier.

pour ce faire j'ai une macro qui ressemble à ca :

SUMIF(A:A,">01/01/2006",B:B)

mais je n'arrive pas à prendre en compte la seconde date (31/01/2006) pour faire mon interval.

je pense que ca ne doit pas etre trop compliqué (à moins que cette focntion ne le permette pas), je dois seulement avoir un problème de syntaxe, de formulation...

merci

2 réponses

Bonjour,
en fait tu peux contourner le probleme de la maniere suivante :
soit 3 dates = date1, date2, date3.
On a SUMIF(,"<date1",)= a
SUMIF(,"<date2",)= b
SUMIF(,"<date3",)= c
Pour avoir les valeurs respectant la condition1 date1< ...< date2, il n'y a plus qu'a soustraire a de b
SUMIF(,condition1,)=b-a.
pour la condition2 : date2<..<date3, on aura : SUMIF(,condition2,)=c-b.
Est-ce clair?
Bonjour,
Voici une formule format conditionelle a adapter

date début en D1
date fin en D2

{=SOMME((B1:B25)*(A1:A25>=(D1))*(A1:A25<=(D2)))}


Utilsfr
http://utilsfr.new.fr
Applications, Utilitaires, Macros, Fonctions, Formulaires, Graphiques Excel