Testdisk et partition système passée en RAW

Résolu/Fermé
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 - Modifié par Cyboo le 21/12/2016 à 19:37
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 - 27 déc. 2016 à 10:38
Bonjour,

Sur un ACER aspire E-15, le démarrage n'arrive pas jusqu'à Windows.

J'ai tenté un chkdsk, il partait pour 999h.

Diskpart trouve la partition principale en raw (voir photo)

Avec un live cd Xubuntu, impossible de monter le disque : "...unsafe state" je crois.

A partir de Xubuntu j'ai lancé Testdisk, je ne comprend pas trop, je ne sais pas si quelqu'un saurait interpréter les photos.
Il arrive à retrouver une arborescence mais je ne vois pas le dossier user.

Pensez-vous que je puisse passer la partition de 900gb de D à P et recouvrer les données ?

Sinon une analyse avec Photorec ? Format NTFS ?

Avec GNU ddrescue ? mais si j'ai un disque externe il n'est pas vide, même s'il a assez de place par rapport aux données originelles, je ne sais pas si ddrescue a besoin d'1GB pour faire l'image de tout le disque endommagé

A part ça, pour info je ne peux démonter le pc pour mettre le disque dans un boitier externe

Merci d'avance





A voir également:

4 réponses

Passionofdream Messages postés 820 Date d'inscription mardi 21 juillet 2015 Statut Membre Dernière intervention 11 mai 2021 303
21 déc. 2016 à 20:45
Bonsoir,
Avant tout il te faut récupérer tes données

Sous linux lance Testdisk dans un terminal

puis
Create
Sélectionne le disque dur "malade"
Proceed
Intel
AnalyseQuick Search
Touche p sur le clavier puis la touche Entrée
Sélectionne le dossier que tu souhaites récupérer
Touche c pour copier sur un autre support

Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
Modifié par Cyboo le 21/12/2016 à 21:11
Merci de ton aide

C'est un Windows 8 (désolé j'ai oublié de préciser) et Testdisk trouve par défaut le système de partitions en GPT/EFI. il me semble qu'il faut le laisser ainsi ?

Pour sauvegarder les données le problème c'est qu'après avoir fait p, il trouve bien une arborescence (dossiers Intel, OEM, program files par ex) mais pas le dossier utilisateur. On voit l'arborescence sur la 4ème photo.
0
Passionofdream Messages postés 820 Date d'inscription mardi 21 juillet 2015 Statut Membre Dernière intervention 11 mai 2021 303
21 déc. 2016 à 21:19
tu as essayé sur chaque partition ?
0
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
21 déc. 2016 à 21:25
Oui,

les deux premières sont des partitions système de 600 et 300mb

Les deux dernières sont des 17gb, une dit "can't open systemfile", et l'autre semble comporter des dossiers propre à une partition de recovery
0
Passionofdream Messages postés 820 Date d'inscription mardi 21 juillet 2015 Statut Membre Dernière intervention 11 mai 2021 303
21 déc. 2016 à 21:30
sur la photo 4 j'ai vu un next tu peux y accéder ?
0
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
Modifié par Cyboo le 21/12/2016 à 21:38
oui,

en dessous de hyberfile.sys il y a deux autres .sys (pagefile et swapfile), puis un grand vide et un "next" non accessible
0
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
Modifié par Cyboo le 21/12/2016 à 22:07
Erreur
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
Modifié par Cyboo le 21/12/2016 à 22:07
Désolé je vois que le scan travaille encore, je modifie le post au dessus
0
Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
Modifié par Cyboo le 22/12/2016 à 22:02
Bonjour Passionofdream,

tu peux voir le résultat en photo.

J'en avais déjà fait un auparavant, le résultat était sensiblement identique juste les nombres start, end, size, un peu différents, mais l'ordre de grandeur était le même.

Et donc seule la partition marquée Mac HFS donne un résultat, mais en fait le même que sur la première photo, avec l'arborescence sans le dossier utilisateur. Et les autres partitions donnent, je crois, toutes le "can't open...file system maybe damaged".

De toute façon, j'ai passé Photorec et retrouvé quelques fichiers, dont des photos. J'ai trouvé une discussion assez similaire sur cgsecurity.org et j'y ai aussi ouvert un topic.

J'aimerais au final pouvoir faire redémarrer ou réinstaller Windows. Je continue de travailler sur le pc et je reviendrai mettre le résultat ici.

Merci de t'être penché sur le cas.

Cyboo Messages postés 217 Date d'inscription vendredi 28 décembre 2012 Statut Membre Dernière intervention 15 octobre 2022 23
Modifié par Cyboo le 27/12/2016 à 10:51
A priori Photorec a retrouvé la plupart des fichiers.

Pour réinstaller Windows je n'ai rien changé dans Testdisk.

La réinitialisation de Windows à l'état d'usine indiquait un message d'erreur ("partition de lecteur manquante" quelque chose dans le genre)

J'ai lancé Gparted qui n'arrivait pas à trouver les infos sur la partition de 900 gigas (triangle d'avertissement) qui portait le système, je pensais que le message d'erreur provenait de là.
Je l'ai reformatée en ntfs mais toujours pas possible de réinitialiser.

J'ai réinstallé un iso de windows 8.1 et ai voulu lancer la réinitialisation.
cela disait qu'il manquait des fichiers que le dvd trouverait, j'ai mis le dvd lancé la réinitialisation et si ce n'est en fait pas le Windows d'origine qui a été réinstallé, il a retrouvé la clé de licence.

Je ne sais pas si le disque est vraiment mort, on verra combien de temps cette "réparation" tiendra, mais problème résolu pour ma part.