Ne pas calculer une somme si cellule vide [Résolu/Fermé]

Signaler
Messages postés
611
Date d'inscription
lundi 7 mai 2007
Statut
Membre
Dernière intervention
7 août 2020
-
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
-
Bonjour,

Je souhaiterai connaître la formule afin de m'envoyer un message d'erreur si une des cellules de mon calcul est vide.

Exemple ma cellule A5 :
=A1+A2+A3+A4

mais si une de ces cellules est vide, je voudrais qu'il y ait un message en A5 me disant que la somme est impossible car une de ces cellules est vide. je pense qu'il faille utiliser la formule ESTVIDE, mais je ne sais pas comment.

Merci de votre aide.

2 réponses

Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 433
Bonjour

=SI(NB.SI(A1:A4;"");"calcul impossible";SOMME(A1:A4))

crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61142 internautes nous ont dit merci ce mois-ci

Messages postés
611
Date d'inscription
lundi 7 mai 2007
Statut
Membre
Dernière intervention
7 août 2020
49
Merci de votre réponse. Toutefois je me confronte à une limite, car si les cellules ne sont pas adjacentes (E3,H3,M3,P3,R3), excel me dit que j'ai rentré un nombre trop important d'arguments...

Visiblement, il n'accepte que 3 cellules non-adjacentes...

Avez-vous une idée ?
Messages postés
25248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2020
5 433 >
Messages postés
611
Date d'inscription
lundi 7 mai 2007
Statut
Membre
Dernière intervention
7 août 2020

Re
effectivement, ce n'est pas la même question!
=SI(OU(E3="";H3="";M3=;P3="";R3="");"";E3+H3+M3+P3+R3)
crdlmnt
Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
58
Bonjour Aztek , Vaucluse.

En prenant en compte ton dernier message ,

soit dit en passant, on passe de 4 cellules adjacentes à 5 cellules sur une ligne.

Berf dans ce cas :

=Si(OU(E3="";H3="";M3="";P3="";R3="");"Calcul impossible";Somme(E3;H3;M3;P3;R3))

Cordialement,
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61142 internautes nous ont dit merci ce mois-ci

Messages postés
611
Date d'inscription
lundi 7 mai 2007
Statut
Membre
Dernière intervention
7 août 2020
49
Merci Fahora. Effectivement, je n'avais pas été très clair dans ma question, pensant que cela fonctionnerait si les cellules n'étaient pas adjacentes, mais visiblement non.

Merci à tous pour votre aide !