Soustraction de 2 cellules avec conditions, ligne par ligne [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mardi 6 décembre 2016
Statut
Membre
Dernière intervention
6 décembre 2016
-
Messages postés
53146
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
-
Bonjour,

J’essaie de faire un tableau avec le boulot, mais il me tiens assez chaud :)

Je cherche à simplifier les kilomètres de formules que j'ai du faire pour extraire des données du tableaux suivant plusieurs conditions,

Dans la plage désignée, et ce, ligne par ligne ( il ne faut pas mélanger en calculant verticalement)

Je souhaite arriver à :

Si cellule A="Texte" ET B="Texte" alors calculer C-D

La formule est simple pour 1 ligne, sauf que, pour une grande plage, la formule devient gigantesque car il faut détailler ligne par ligne pour ne pas que le calcul sois fait sur toute une colonne, n'y a t-il pas un moyen de simplifier ?

La formule pour 1 ligne ressemble à sa SI((I8="Client")*(D8="Paris");G8-H8;0)

Existe-il une façon pour faire "dans la plage de X à Y" ligne par ligne ?

Merci pour votre aide !

3 réponses

Messages postés
53146
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
15 132
Bonjour.

Impossible pour nous d'intervenir sans disposer de ton fichier
(ou d'un fichier-exemple).
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Messages postés
3
Date d'inscription
mardi 6 décembre 2016
Statut
Membre
Dernière intervention
6 décembre 2016

Voila un extrait-exemple :)

http://www.cjoint.com/c/FLgbdyb5FTz

Merci.
Messages postés
53146
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
15 132
Bien !
La fonction SOMMEPROD est celle qui te sauvera :
Dans chacune des cellules de la plage C14:G19 mettre la formule
=SOMMEPROD( ($C$2:$C$7=$A14)*($H$2:$H$7=C$13)*($F$2:$F$7-$G$2:$G$7) )
Messages postés
3
Date d'inscription
mardi 6 décembre 2016
Statut
Membre
Dernière intervention
6 décembre 2016

Merci beaucoup ! J'ai pu l'adapter !
Messages postés
53146
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
15 132 >
Messages postés
3
Date d'inscription
mardi 6 décembre 2016
Statut
Membre
Dernière intervention
6 décembre 2016

Tant mieux ... et conserve précieusement cette utilisation de SOMME.PROD ; elle te servira souvent, maintenant que tu as vu comment l'appliquer !
Cordialement.