Somme Si double condition * valeur liée à ces deux conditions

[Résolu/Fermé]
Signaler
-
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
-
Bonjour,

Je viens tous juste débuter sur excel et je commence un calendrier mensuel afin de calculer mes frais de déplacement en fonction des différentes missions.

Pour faire simple le calendrier est composé d'une semaine sur un ensemble de ligne donc plusieurs pour un mois et les jours correspondent aux colonnes.

Par jour j'annote l'ordre de mission, qui par un tableau déjà prérempli indique le type d'indemnité pour la journée, il y a 7 types.

Ensuite je choisis par liste déroulante le format de travail ( Réguliere; HD; 2x8; Nuit 3x8; Weekend).

J'ai préalablement rédigé les tableaux pour chaque type de remboursement pour chaque format de journée, exemple : "type 2" "2x8" "prime organisation"----> "15€"

J'ai donc besoin de compter par types le nombre de format de travail apparaissant et le multiplier par les frais remboursés en fonction de ces conditions.

Ex: Compter les "2x8" sur une semaine du type de remboursement "Type1" et les multiplier la somme comptée par la case correspondantes à ces frais.

Pourriez vous m'aider pour la formule?

Je vous remercie d'avance.


3 réponses

Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 053
Bonjour
essayez avec ce tte formule à adapter à vos besoins:

=SOMMEPROD(champ1=valeur1)*(champ2=vameur2)*(Champ3=valeur3)*(etc...))*(tarif)

avec des champs de la même hauteur, et limités avec des N° de ligne
(pas de A:A par ex mais A1:A10)

Pour info

=SOMMEPROD...avec uniquement des égalités compte le nombre de cas répondants aux conditions

=SOMMEPROD((...)*(...)*(...)*(champ de valeurs num))
faits la somme des valmeurs du dernier champs sdans les, lignes qui remplissent les conditions

Autre possibilté sur Excel à partir de 2007 (admet des champs avec seulement les indications de colonnes)

compter le nombre de cas:

=NB.SI.ENS(champ1;condition1;champ2,condition2;etc....)

sommer un champ selon les cas:

=SOMME.SI.ENS(Champ à sommer;champ1;cond1;etc...)

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
54681
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2021
16 577
Bonjour.

Non : On ne peut absolument pas t'aider sans disposer de ton fichier.
Ta longue explication n'est vraiment pas exploitable en l'état ...
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Bonjour messieurs,

Merci Vaucluse de m'avoir compris et merci d'avoir essayé Raymond.


=NB.SI.ENS(champ1;condition1;champ2,condition2;etc....)

est la formule qui répond exactement à ce que je voulais merci pour cette réponse très utile.

J'avance petit à petit sur mon fichier et ça fais plaisir !

Je vais m'empresser de créer une nouvelle question.

Cordialement.
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 053
Ok alors je passe le sujet en résolu
si autre question, ouvrez un nouveau fil
Bonne route
crdlmnt