Résultat résultant combinaison de 2 valeurs (suivant tableau) [Résolu/Fermé]

Signaler
-
 pauline -
Bonjour,

Je suis en train de construire un tableau Excel avec de nombreuses colonnes. J'aimerais gagner en temps et en simplicité pour remplir certaines colonnes avec des formules. Il y a cependant un cas qui me pose un problème :

--> J'ai deux colonnes, "quantité" et "fréquence". Chacune contient une valeur comprise entre 1 et 5. Dans ma troisième colonne "exposition potentielle" j'aimerais reporter un nombre (compris entre 1 et 5) qui correspond à la combinaison des deux premières colonnes suivant un tableau établi (cf tableau ci-dessous).

Quelqu'un pourrait-il m'aider à trouver la formule adéquate ?
Merci d'avance.

Pauline


Quantité ...+.... Fréquence .....=... Exposition potentielle
.....1.........+..........1.............=................1
.....1.........+..........2.............=................1
.....1.........+..........3.............=................1
.....1.........+..........4.............=................1

.....2.........+..........1.............=................2
.....2.........+..........2.............=................2
.....2.........+..........3.............=................2
.....2.........+..........4.............=................2

.....3.........+..........1.............=................3
.....3.........+..........2.............=................3
.....3.........+..........3.............=................3
.....3.........+..........4.............=................4

.....4.........+..........1.............=................3
.....4.........+..........2.............=................4
.....4.........+..........3.............=................4
.....4.........+..........4.............=................5

.....5.........+..........1.............=................4
.....5.........+..........2.............=................5
.....5.........+..........3.............=................5
.....5.........+..........4.............=................5




2 réponses

Messages postés
1941
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
23 août 2020
142
Bonjour,

Cela s'appelle traditionnellement de la recherche multicritère où tu peux utiliser la puissante combinaison INDEX+EQUIV (https://silkyroad.developpez.com/excel/indexequiv/#LIV-A).
Sinon on peut imaginer une formule bizarre à base de SI :
=SI(A1=5;5-SI(B1=1;1;0);0)
+SI(A1=4;4-SI(B1=1;1;0)+SI(B1=4;1;0);0)
+SI(A1=3;3+SI(B1=4;1;0);0)
+SI(A1=2;2;0)
+SI(A1=1;1;0)
Merci pour tes explications, je viens de lire et de bidouiller un peu mon fichier et j'y suis arrivée avec la formule index !

Et merci d'avoir été aussi réactif !
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
552
Bonjour Pauline

Avec la fonction INDIRECT et EQUIV voir fichier

http://www.cjoint.com/c/FKskvp1Todx

Merci également pour ta réponse ! Je l'ai vue seulement après y être arrivée en bidouillant mon fichier avec la formule expliquée au dessus par Zoul67.

En tout cas merci d'avoir été aussi réactif !