Faire la somme d'un produit

Fermé
MelynBzt Messages postés 2 Date d'inscription jeudi 10 novembre 2016 Statut Membre Dernière intervention 10 novembre 2016 - 10 nov. 2016 à 16:25
Raymond PENTIER Messages postés 58453 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 24 mai 2024 - 10 nov. 2016 à 17:35
Bonjour à tous,

Voilà, ça fait quelques minutes, voire même quelques heures, que j'ai un blocage sur Excel... Je voudrais faire la somme du produit d'une plage de critères et d'un critère seul, qui en plus sont tous dans la même colonne. SOMMEPROD ne fonctionne évidemment pas, puisque c'est entre 2 colonnes avec autant de critères.

Y-a-t-il une autre solution que de taper à la main?

Merci bien!

2 réponses

Raymond PENTIER Messages postés 58453 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 24 mai 2024 17 117
Modifié par Raymond PENTIER le 10/11/2016 à 16:40
Bonjour.

"SOMMEPROD ne fonctionne évidemment pas, puisque c'est entre 2 colonnes avec autant de critères" là, tu t'avances un peu trop !

=SOMMEPROD(A2:A20*A25) te donnera la somme de toutes les multiplications des cellules de A par la cellule A25 ...

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
0
MelynBzt Messages postés 2 Date d'inscription jeudi 10 novembre 2016 Statut Membre Dernière intervention 10 novembre 2016
Modifié par MelynBzt le 10/11/2016 à 16:54
Justement ça ne fonctionne pas... J'ai même essayé de nommer le critère seul ou encore de noter "$L$3", et ça ne fonctionne pas non plus :/

Mais merci pour ta réactivité!!
0
Raymond PENTIER Messages postés 58453 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 24 mai 2024 17 117
10 nov. 2016 à 17:29
Je ne me serais pas permis de proposer une formule sans l'avoir d'abord testée !
Elle marche parfaitement ...
https://www.cjoint.com/c/FKkqB2SPauZ
https://www.cjoint.com/c/FKkqCKwF16Z
0
Raymond PENTIER Messages postés 58453 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 24 mai 2024 17 117
10 nov. 2016 à 17:35
Si tu avais envoyé ton fichier, comme il est d'usage, les éventuelles erreurs de ta part auraient été repérées et signalées (comme d'avoir autre chose qu'une valeur numérique dans une des cellules) ...
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
0