Trait d'union court avec Word 2010

Résolu/Fermé
VictimeDeLinformatique
Messages postés
169
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
18 août 2020
- 2 nov. 2016 à 14:33
VictimeDeLinformatique
Messages postés
169
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
18 août 2020
- 3 nov. 2016 à 15:23
Bonjour,

Depuis quelque temps, je constate que Word 2010 change automatiquement les traits d’union courts - (en haut à droite du clavier des lettres) en traits d’union plus longs – (qu'on obtient normalement en tapant Ctrl + trait d’union dans le bloc de chiffres). Je ne m'en rends pas compte de suite, parce qu'il fait cela avec retard voire seulement à la réouverture du ficher.

Pas moyen de trouver que faire pour éviter cela. Dans les options d’autocorrection cela ne semble pas prévu. J'y trouve uniquement la possibilité de cocher ou décocher le changement automatique de deux traits courts en un trait long, ce qui n'est pas le sujet de ma demande.

Avec Word 2007 je n'avais pas ce problème. Pourquoi est-ce que Microsoft a introduit cette anomalie à l'occasion de l'édition d'une nouvelle version de Word? Pourquoi ne pas se contenter d’améliorer ce qui existe ?

Est-ce que quelqu'un connaît la solution? Merci d'avance.

1 réponse

m@rina
Messages postés
17449
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
10 904
2 nov. 2016 à 20:44
Bonjour,

Au'appelles-tu "les traits d’union courts - (en haut à droite du clavier des lettres) "?

Un trait d'union se fait avec la touche 6 du clavier et quelle que soit la version de Word, je n'ai jamais vu de problème avec ça.
Et je ne vois pas de "tiret court" en haut à droite de mon clavier... Juste le signe Moins (-) en haut à droite du clavier numérique.

m@rina


0
VictimeDeLinformatique
Messages postés
169
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
18 août 2020
4
2 nov. 2016 à 21:30
Merci m@rina,

Comme j'ai un clavier belge, les touches ne sont peut-être pas réparties de la même façon que sur les claviers utilisés en France.

Quand je tape 6, j'obtiens le chiffre six.

Possible que ce que j'appelle le trait d'union court corresponde au signe moins. La question deviendrait donc: Que faire pour que le signe moins (-) ne devienne pas plus long sous les conditions décrites dans ma demande?

Bonne soirée
0
m@rina
Messages postés
17449
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
10 904
3 nov. 2016 à 00:46
Effectivement, le clavier belge, bien qu'AZERTY, est différent du clavier français :
http://www.jbinformatique.be/tutoriels/tuto/W10-65

Cela étant, il s'agit bien du même tiret que celui de la touche 6 du clavier FR, et aucun problème wordien n'a été recensé sur le sujet. La touche Moins du clavier numérique donne la même chose.

Concernant les corrections automatiques, ce qu'il faut savoir avec le clavier français :
2 tirets donnent un tiret cadratin
2 tirets avec avant et après une espace donnent un tiret semi-cadratin.
A noter que la transformation se fait après l'espace ou le retour marge situé après le mot qui suit le tiret.

Et comme je n'ai jamais vu de problèmes avec ça, du coup j'ai téléchargé le clavier belge. Et là, effectivement, je constate ce que tu dis : un tiret se transforme automatiquement en tiret semi-cadratin dès lors qu'il y a une espace avant et après, alors qu'avec le clavier français, il faut faire 2 tirets.
Par contre, le tiret cadratin fonctionne comme pour le clavier français.

Il te reste donc à désactiver la correction automatique dont tu as parlée, et ça fonctionne, même si l'option (--) est prévu pour le clavier français.

m@rina
0
VictimeDeLinformatique
Messages postés
169
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
18 août 2020
4 > m@rina
Messages postés
17449
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
26 mai 2022

3 nov. 2016 à 14:42
Désactiver la correction automatique ne donne pas le résultat escompté. Cependant, j'ai constaté que la transformation automatique du tiret (unique) en un tiret semi-cadratin se fait même s'il n'y a qu'un seul espace. Je travaille pour l'instant en allemand, or dans cette langue il peut arriver dans certains cas qu'un mot commence par un tiret. Si ce que je viens de constater se confirme, il suffirait de mettre un signe invisible devant le tiret pour qu'il ne change plus, par exemple un espace insacable. Reste à voir si cela ne peut pas poser des problèmes lorsqu'on utilise une mise en page justifiée.

On peut donc considérer provisoirement le problème comme résolu, même si je me demande pourquoi ce recul par rapport à Word 2007.

Merci
0
m@rina
Messages postés
17449
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
10 904
3 nov. 2016 à 15:12
C'est curieux car ça paraît quand même spécifique au clavier belge par rapport au clavier français. Je n'ai pas testé d'autres claviers.

Par contre, chez moi le problème se résout si je désactive la correction automatique.
As tu bien décoché l'option sous l'onglet "Lors de la frappe" et non sous l'onglet "Mise en forme automatique" ?
Et sinon, le tiret se transforme uniquement quand il y a une espace avant et une espace après.

m}rina
0
VictimeDeLinformatique
Messages postés
169
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
18 août 2020
4
3 nov. 2016 à 15:23
Aurais-je mal regardé? Je viens de refaire brièvement l'essai. L'option en question est bien décochée. Et, effectivement, le problème ne se pose plus et ce, qu'il y ait un espace avant et après, uniquement avant ou uniquement après, ou pas d'espace du tout. Le problème est donc vraiment résolu.

Merci
0