Vous avez placéun nombre trop important d'arguments pour cette f [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
dimanche 16 octobre 2016
Statut
Membre
Dernière intervention
16 octobre 2016
-
Messages postés
25099
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
-
Bonjour,

Quelqu'un peut il m'aider?

Cette formule fonctionne avec 2 "si" mais pas avec la 3ème formule rajoutée
=> vous avez placé un nombre trop important d'arguments pour cette fonction

=SI(C3="g";RECHERCHEV(I3;Relaisg;2;VRAI);SI(C3="f";RECHERCHEV(I3;Relaisf;2;VRAI));SI(C3="m";RECHERCHEV(I3;Relaism;2;VRAI)))

Merci par avance

2 réponses

Messages postés
25099
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 261
Bonjour

probablement une parenthèse de trop derrière le 2° VRAI

=SI(C3="g";RECHERCHEV(I3;Relaisg;2;VRAI);SI(C3="f";RECHERCHEV(I3;Relaisf;2;VRAI);SI(C3="m";RECHERCHEV(I3;Relaism;2;VRAI)))

mais vous pouvez écrire poklus ismplment:

=RECHERCHEV(I3;SI(C3="g";Relaisg;SI(C3="f";Relaisf;Relaism));2;0)

crdlmnt
Messages postés
2
Date d'inscription
dimanche 16 octobre 2016
Statut
Membre
Dernière intervention
16 octobre 2016

Super Merci.
ça fonctionne.

J'ai pris la première, le seconde ne fonctionne pas.

Encore merci pour la réactivité.
Messages postés
23384
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 mai 2020
6 150
Tu penses te faire greffer des doigts bientôt vaucluse ? :-)
Messages postés
25099
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 261
noin mon ami eric... j'en ai déjà de trop, là... et à mon age on ne sait plus trop où les mettre!
Crdlmnt!
Messages postés
5476
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
18 mai 2020
438
annulé