Formule index(;equiv;) avec une plage de recherche variable [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
lundi 11 avril 2016
Statut
Membre
Dernière intervention
15 septembre 2016
-
Messages postés
11
Date d'inscription
lundi 11 avril 2016
Statut
Membre
Dernière intervention
15 septembre 2016
-
Bonjour, et merci d'avance pour votre aide.

J'ai un petit problème que je n'arrive pas résoudre (Excel 2013), pourtant je crois que ce n'est pas si compliqué... Bref je n'en sors pas !

Cela se passe dans le fichier cjoint http://www.cjoint.com/c/FIoip6vypJ8

Dans l'onglet Classement, sur la cellule B52 :
=SIERREUR(INDEX('T2'!$A$2:$N$2000;EQUIV($A52;'T2'!$N$2:$N$2000;0);1);"")

En réalité, si en A51 j'ai la première occurrence de 47, alors je rapatrie de la feuille T2 les données concernant la première occurrence de 47 en 'T2'!N2:N2000, soit dans ce cas-ci rapatrier les données 'T2'!A121. C'est bon.

Mais en A52 j'ai la seconde occurrence de 47 (47 est déjà présent plus haut dans la colonne A, en A51 précisément). Dans ce cas je dois rapatrier en B52 le contenu 'T2'!A123

Il doit y avoir de l'INDIRECT() et de l'NB.SI() là-dedans, mais je n'y arrive pas...
Avez-vous une solution?

Un tout grand merci d'avance.

Damien

2 réponses

Messages postés
2709
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
11 août 2020
361
Bonjour,

Tu transformes ta feuille t2 en tableau, tu retires les doublons, et tu tries avec la derniere colonne (du +petit au +grand)
Et tu "rapropries" ...

Crdmt

https://www.cjoint.com/c/FIonULoTlSD
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 396
Bonjour
une solution ici avec une colonne de codage qui peut être masquée ou sur une autre feuille
revenez besoin de complément d'info

https://www.cjoint.com/c/FIonWk55CmC

crdlmnt


Messages postés
11
Date d'inscription
lundi 11 avril 2016
Statut
Membre
Dernière intervention
15 septembre 2016

C'est exactement cela, merci bcp Vaucluse.