Formule de calcul à conditions multiples [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016
-
Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016
-
Bonjour,
J'ai un tableau Excel à 3 colonnes dont les 2 premières sont des dates au format AA/MM et la troisième une valeur texte. Je voudrais qu'Excel me donne une valeur texte définie (A FAIRE, FAIT, EN ATTENTE) en fonction des dates indiquées dans les colonnes précédentes comme suit :
Si dans la colonne 1, une date est remplie et que dans la colonne 2 aussi, alors indiquer FAIT
Si dans la colonne 1, une date est remplie mais pas dans la colonne 2, alors indiquer A FAIRE
Si dans la colonne 1, aucune date n'est remplie alors indiquer EN ATTENTE
J'ai essayé avec SOMME.SI et SI mais ca ne fonctionne pas. J'ai des résultats mais pas ceux attendus.
Merci à celles et ceux qui prendront un peu de leur temps pour me répondre !

3 réponses

Messages postés
25757
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 janvier 2021
5 723
Bonjour

=SI(ET(A1>0;B1>0);"fait";SI(A1>0;"à faire";"en attente"))

à condition que vous n'ayez pas de cas avec une date en B et pas en A

crdlmnt


Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016

Mais justement ça peut être le cas. Il faudrait que Excel cherche la valeur en A1, si elle est ok alors il cherche la valeur en B1 et ensuite me donne le résultat A FAIRE ou FAIT. Si aucune valeur en A1 alors EN ATTENTE.
Avec votre formule, les résultats ne sont pas justes. :(
Messages postés
31108
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
21 janvier 2021
3 198
Bonjour,

Un SI avec des ET devraient suffire non ?
Un truc du genre :

SI( ET(A1<>"";B1<>"");"FAIT";SI(ET(A1<>"";B1="");"A faire";"En attente"))

Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016

Merci mais la formule ne me donne pas le bon résultat. :(
Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016

Alors merci à vous 2 qui m'avez répondu, j'ai fini par trouver une formule qui fonctionne et me donne les bons résultats.
Mais quand je change les données des cellules A1 et B1, le résultat ne change que si je fais F2 dans la cellule comme pour modifier la cellule.
Bizarre non ?
Vos avis et conseils ?
Messages postés
31108
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
21 janvier 2021
3 198
N'aurais tu pas désactiver le "calcul automatique" dans ton excel ?
Regarde dans les options pour le réactiver.
Messages postés
25757
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 janvier 2021
5 723
vérifier vos options Excel
sur Excel à partir de 2007
Ruban / Onglet formule / tout à droite "option de calcul et cochez "automatique"

revenez si ça ne suffit pas
crdlmnt
Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016

Oui c'est ça ! Mille merci pour votre réponse ! Tout fonctionne !
Merci encore !
Utilisateur anonyme >
Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016

Bonjour lumi.mlca, je te propose une formule encore plus courte :
=SI(A1="";"EN ATTENTE";SI(B1<>"";"FAIT";"A FAIRE"))
Messages postés
8
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
25 août 2016
> Utilisateur anonyme
oui merci albkan ! Elle marche aussi ta formule et est plus simple. Merci beaucoup.