Difficulté fonction EQUIV/INDEX imbriquée

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
24 août 2016
-
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
-
Salut salut,
Je suis actuellement en stage et pour un projet je dois créer un fichier excel,
dans une partie de ce fichier excel j'ai deux tableaux sur 2 pages différentes.
1er tableau:
colonne A: numéro des animaux
colonne B: vide

2eme tableau;
colonne A: numéro des animaux (certains animaux sont identiques à ceux du tableau un mais pas tous)
colonne B: date d'arrivée de l'animal

Je souhaite que dans la colonne B de mon premier tableau apparaisse à coté de chaque numéro d'animal, sa date d'entrée si cet animal est présent dans le tableau 2

Pouvez-vous m'aider ?
C'est assez urgent je dois finir mon projet rapidement, on compte sur moi, et j'ai déjà essayé mais pas moyen ...

Merci d'avance à ceux qui m'apporteront leur aide ...

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
536
Bonjour,

En joignant un fichier exemple, tu auras plus de chance de recevoir une réponse adaptée.
Pour cela, tu peux utiliser https://www.cjoint.com/

A+
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
6 067
Bonjour
avec ce que vous écrivez, iNDEX EQUIV n'est pas utile
en commençant en B2 1° tableau
si le tableau 2 est A:B en feuil2:

=RECHERCHEV(A2;Feuil2!A:B;2;0)

devrait suffire

et pour éviter des éventuels affichages de N/A si A n'existe pas en feuille 2

à partir d'Excel 2007:

=SIERREUR(RECHERCHEV(A2;Feuil2!:A:B;2;0);"")

.. ou un texte genre "inexistant" à placer entre les derniers guillemets

et si vous tenez à INDEX/EQUIV

=INDEX(Feuil2!A:B;EQUIV(A2;Feuil2!A:A;0);2)

crdlmnt





Messages postés
3
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
24 août 2016

Je te remercie pour ta réponse, mais quand je fais ça il m'affiche le numero au lieu de la date ...
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
6 067 >
Messages postés
3
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
24 août 2016

alors c'est que vos tableaux ne sont pas fait comme vous dites, ou que la formule est mal écrite
RECHERCHEV va chercher dans la 1° colonne de Feuil2!A:B (soit A donc) la valeur de A2 et ressort celle de la 2° colonne, (soit en B)
sauf une faute de frappe de ma part dans la 2° (SIERREUR... ) içl faut enlever les deux point derrière entre point d'exclamation et A
qu'avez vous écrit comme formule?
à vous lire
Messages postés
3
Date d'inscription
mercredi 24 août 2016
Statut
Membre
Dernière intervention
24 août 2016

En fait c'est bon j'ai réussi ! Merci beaucoup :)
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
6 067
Pas de quoi, je passe le sujet en résolu.
Bonne route
crdlmnt