Compter les valeurs sans doublons et les trier [Résolu/Fermé]

Signaler
Messages postés
80
Date d'inscription
samedi 3 octobre 2015
Statut
Membre
Dernière intervention
4 juillet 2018
-
Messages postés
80
Date d'inscription
samedi 3 octobre 2015
Statut
Membre
Dernière intervention
4 juillet 2018
-
Bonjour !

J'ai posté le message suivant il y a quelques jours :

"Bonjour !

J'ai deux colonnes dans deux fichiers Excel, et il faut que je trouve le nombre de cellules qu'il reste une fois que tous les doublons sont supprimés. Au lieu de faire ça à la main, pour ne pas y passer des heures, j'ai recherché comment utiliser la fonctionalité sur Internet, puis j'ai regardé au niveau des Macros, mais je n'ai toujours rien trouvé...

Mon problème, c'est que j'ai environ 500 valeurs dans une cellule, et pas loin de 800 dans l'autre. Et les valeurs en doublon ne sont donc pas forcément alignées.

Comment faire, donc, pour trouver les doublons ? Est-il possible de trouver un code pour trier, ou une fonctionnalité ?

Merci d'avance :)
"

Les réponses que j'ai eu sont les suivantes :

"Bonjour

En supposant les 500 valeurs en colonne A à partir de A2 et les 800 en colonne B à partir de B2, en C2 mettre la formule :=si(NB.SI(A:A;B2)=0;1;0) puis étirer la formule vers le bas (double clic sur carré noir en bas à droite de C2)
Ensuite en D1 la formule =SOMME(C:C) donnera le nombre de cellules en B qui n'ont pas de doublons en A

Cdlmnt
Via
"
De via55

"Bonjour,

il faut que je trouve le nombre de cellules qu'il reste une fois que tous les doublons sont supprimés.

Avec cette formule matricielle à valider par ctrl+majuscule+entrée simultanées tu obiens le nombre des sans doublons avec tes listes (à adapter) en colonne A et B.
=SOMME(NB.SI($A$1:$A$800;$B$1:$B$800))
"
De gbinforme

Ma question maintenant est la suivante : j'ai réussi à compter ceux qui n'ont pas de doublons, donc les valeurs avec lesquelles je dois travailler maintenant. En revanche, il faudrait que je les trie. Est-il possible de faire ça automatiquement, ou est-ce que je dois les trier à la main ?

Merci d'avance pour vos réponses !

1 réponse

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 495
Bonjour
au plus simple en partant du début, sans formule:
Copier A2 àA500, coller sur D2:D500
Copier B2:B800 coller à la suite dans la colonne D
(ou une autre bien sur), mais toutes les valeurs dans la même colonne et si possible une colonne non attenante à A:B pour éviter les questions d'Excel.

Ensuite sélectionnez la colonne D
Ruban onglet données et dans outils de données > "supprimer les doublons"

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
80
Date d'inscription
samedi 3 octobre 2015
Statut
Membre
Dernière intervention
4 juillet 2018
12
C'est tellement simple parfois qu'on y pense même pas ! Merci beaucoup pour cette réponse !

Maintenant, reste plus qu'à comprendre ce que les chiffres me disent... Normalement, les valeurs de la colonne A apparaissent forcément dans la B. Donc là j'ai 580 valeurs en A et 806 en B. J'ai trouvé 812 valeurs sans doublons... Et la formule que j'ai mise en haut m'indiquait 333... Ah, l'informatique !

Merci encore, et bonne journée :)
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
488 >
Messages postés
80
Date d'inscription
samedi 3 octobre 2015
Statut
Membre
Dernière intervention
4 juillet 2018

Bonjour,

Attention, la méthode proposée par Vaucluse (que je salue) supprime les valeurs en doublon. La première valeur reste donc dans la liste.
Le résultat ne sera pas le même si tu supprimes toutes les valeurs en double.

Exemple :
Liste 1 : Toto, Titi, Tata
Liste 2 : Titi, Tutu

La liste globale sans doublon est : Toto, Titi, Tata, Tutu
La liste globale sans valeurs en double est : Toto, Tata, Tutu.

A+
Messages postés
80
Date d'inscription
samedi 3 octobre 2015
Statut
Membre
Dernière intervention
4 juillet 2018
12 >
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016

Gyrus, exact ! Ca doit être pour ça que je trouve toujours un nombre très supérieur à ce que j'espérais trouver... Est-ce que tu saurais comment parvenir à tout supprimer ?
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 495
Pas de quoi..
pour info selon ce que vous écrivez:
si toutes les valeurs de A sont dans B, vous ne pouvez pas avoir plus de 806-580=226 valeurs sans doublon, alors vous avez le choix!!
333 ? 226 ? 812 ?
vérifiez que vos formules concernent bien les bonnes limites de champs
Bon courage
crdlmnt
Messages postés
80
Date d'inscription
samedi 3 octobre 2015
Statut
Membre
Dernière intervention
4 juillet 2018
12
Merci encore pour le conseil !