Supprimer doublons sans décalage de cellules

Résolu/Fermé
info1010
Messages postés
8
Date d'inscription
mercredi 26 janvier 2011
Statut
Membre
Dernière intervention
10 février 2011
- 10 févr. 2011 à 10:03
info1010
Messages postés
8
Date d'inscription
mercredi 26 janvier 2011
Statut
Membre
Dernière intervention
10 février 2011
- 10 févr. 2011 à 11:56
Bonjour,

Dans Excel, j'ai une colonne de données où il y a des doublons que je dois supprimer.
La fonction "supprimer les doublons" de l'onglet "outils de données" du menu "données" fait très bien ce travail sauf qu'elle décale les cellules vers le haut. J'aimerais que les cellules ne soient pas décalées.

Y a t'il une solution?
A voir également:

6 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
10 févr. 2011 à 11:26
Bonjour
exemple à ajuster:
votre liste à partir de A1 en colonne A
en colonne B, la formule en B1 à tirer:
=SI(NB.SI($A$1:A1;A1)>1;"";A1)
en bloquant les premier A1 de la limite de champ, pas le second...
... vous affichera une seule fois les exemplaires de noms de colonne A

Restera plus qu'à faire une copier / collage spécial valeur là ou vous souhaitez la, liste.

Note pour info si besoin:
pour entrer la formule sur 20000 lignes:
si votre liste en A n"='a pas de cellule vide et si vous placer la formule dans une colonne contiguë

entrez la formule en B1

cliquez deux fois sur la petite croix en bas à droite de la cellule

sinon: dans la fenêtre à gauche de la règle des entêtes de colonnes, entrez:
B1:B20000
placez la formule correspondant à B1 et entrez en maintenant la touche ctrl enfoncée.

crdlmnt



9