Etirement d'une cellule fusionnée avec calcul

[Fermé]
Signaler
Messages postés
9
Date d'inscription
mardi 21 juin 2016
Statut
Membre
Dernière intervention
6 septembre 2016
-
Messages postés
26222
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
-
Bonjour,

Voila j'ai une colonne dans un suivi de production ou j'ai cette formule d'inscrite à l'intérieur : =(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D1)*60+2))

Cette formule va chercher dans la feuille DonnéeProduction une somme qu'elle divise par un série de temps espacé de 62 lignes. Jusqu'ici tout va bien.

Mon soucis est que j'inscris cette formule dans une cellule fusionnée de 5, et quand j'étire la formule on m'inscrit :
(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D1)*60+2))(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D6)*60+2))(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D11)*60+2)(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D16)*60+2))

Or j'aimerais qu'on m'inscrive cela dans les formules :
(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D1)*60+2))(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D2)*60+2))(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D3)*60+2))(SOMME(DonnéeProduction!F4:F8))/INDIRECT("TempsPoste!U"&(LIGNE(D4)*60+2))

J'espère avoir été claire, en vous remerciant pour vos futures réponses,

Cordialement,

Pierre

4 réponses

Messages postés
54832
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 octobre 2021
16 724
Interdit, car impossible, de travailler avec des cellules fusionnées ...
Elles ne servent qu'à afficher ; jamais à calculer !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
2228
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 octobre 2021
330
Bonjour
Vous ne dites pas dans quelle colonne se trouve la formule, en attendant, on peut essayer ceci
=SOMME(DonnéeProduction!$F$4:$F$8)/INDIRECT("TempsPoste!U"&(NBVAL($F$1:F1)+1)*60+2)
ici, je l'ai placé en F2 puis étiré vers le bas (F1 ne doit pas être vide).
Remplacer F par votre propre colonne.
Si ce n'est pas ça, mettez un échantillon de votre fichier en pièce jointe.
Cdlt
Messages postés
9
Date d'inscription
mardi 21 juin 2016
Statut
Membre
Dernière intervention
6 septembre 2016

Merci pour votre réponse mais la formule que vous avez écrite ne fonctionne pas, je retrouve le même problème, c'est à dire que quand je l'étire je trouve =SOMME(DonnéeProduction!$F$4:$F$8)/INDIRECT("TempsPoste!U"&(NBVAL($F$1:F1)+1)*60+2) =SOMME(DonnéeProduction!$F$4:$F$8)/INDIRECT("TempsPoste!U"&(NBVAL($F$1:F6)+1)*60+2) =SOMME(DonnéeProduction!$F$4:$F$8)/INDIRECT("TempsPoste!U"&(NBVAL($F$1:F11)+1)*60+2)

J'ai essayé avec des valeurs et les cadences que je trouve sont fausses. Dans l'ordre je devrais trouvé comme cadence 0,2 / 0,1 / 0,01 / 0,05. Or la je trouve que 0,10.
Pourtant je pense qu'il y a quelque chose à faire avec cette fonction NBVAL mais vous supprimez ma fonction ligne donc je sais pas, je maitrise pas du tout les calculs avec les cellules fusionnées.

Excusez moi pour mon ancien message, j'inscrivait la formule dans la colonne E.
Petite erreur de ma part également, sur mon 1er message, mes formules indiquent que je bloque les cellules F4 et F8 alors qu'en réalité non.
Désolé pour ces approximations,

Veuillez trouvez ci joint mon fichier. Ma formule se trouve dans l'onglet cadences, dans la colonne E. J'ai laissé ma formule initiale dans mon fichier.

Encore merci,

Pierre
https://www.cjoint.com/c/FFEhLMzR26v
Messages postés
2228
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 octobre 2021
330
Bonjour
Avec ceci
https://www.cjoint.com/c/FFEmIe6fuil
Cdlt
Messages postés
9
Date d'inscription
mardi 21 juin 2016
Statut
Membre
Dernière intervention
6 septembre 2016

MERCI BCP, car marche avec succès :)
Messages postés
54832
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 octobre 2021
16 724
Oui, Frenchie83 : astucieux !
Messages postés
26222
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083
Bonjour
vous pouvez aussi remplacer dans votre formule:

LIGNE(D1)*60 (qui renvoie 1*60)

par
=(LIGNE(D1)+4)/5)*60

crdlmnt