Modifier des valeurs [Résolu/Fermé]

Signaler
-
 Golastre -
Bonjour,

J'ai une colonne avec des tailles type :
4113
4223
8-9ans

J'aimerais faire en sorte que ces valeurs soient comme cela :
411/3
422/3
9A

Comment faire? Existe-t-il une formule?

Pck mon soucis c'est que je l'ai fait manuellement (avec recherche / remplace) ainsi qu'avec =Subsitue mais dans les deux cas il faut répeter l'opération beaucoup de fois (j'ai environ 15 tailles à changer) et surtout je fais des imports hebdomadaire, et j'aimerai ne pas refaire à chaque fois les manip...

Merci beaucoup pour votre aide précieuse.

1 réponse

Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
63
Bonjour ,

Si tu as ce type de données à coup sur à chaque 4 chiffres ou une écriture du type 8-9ans :
on peut imaginer une formule comme celle-ci :

=SI(ESTNUM(A1);GAUCHE(A1;3)&"/"&DROITE(A1;1);STXT(A1;TROUVE("-";A1)+1;1)&"A")

Il faudra certainement faire un test si l'age est supérieur à 9 ans , mais nous verrons ça plus en détail après avoir eu la confirmation que la formule te convient.

Cordialement,
J'ai bien mis le bon format :)

Ca marchera pour des fichiers d'environ 10 000 cases?
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
63
J'ai mis 900 références possibles et 40000 lignes possibles.

Si je dis de faire attention aux formats , c'est qu'il y a une erreur de format sur la dernière ligne dans le dernier tableau que tu m'as demandé.
J'ai l'impression que ca fonctionne !

Je vais pouvoir reprendre ce tableau pour les différentes tables de correspondance, selon le fournisseur.

Cher Fahora, je te remercie vivement pour ta patience et ton aide plus que précieuse sur le sujet ;)
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
63
Tout le plaisir est pour moi.

N'hésite pas au besoin , et passe le sujet en "résolu".

A bientôt
C'est très gentil :)

Il se peut que quand je ferai les nouveaux fichiers, je sois de nouveau perdu ahahah

Merci beaucoup en tout cas.

A bientôt