Nombres d’occurrences en fonction d'une date et d'un chiffre [Résolu/Fermé]

Signaler
Messages postés
12
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
30 juin 2016
-
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
-
Bonjour,

J'aurais besoin d'aide avec le tableau joint.
Je cherche à compter le nombre d'occurrences d'un nombre spécifique (par exemple 176) en fonction de si ce nombre est comprit dans la série correspondant à la date voulue (par exemple le 04/05/2016).
Pour résumer, je voudrais trouver combien de fois un nombre apparaît en fonction d'une certaine date.

En espérant avoir été assez claire
Merci d'avance

A voir également:

2 réponses

Messages postés
3262
Date d'inscription
mercredi 11 février 2009
Statut
Contributeur
Dernière intervention
8 avril 2021
177
Bonjour,

Une solution :
=NB.SI.ENS()
Tu fais une condition sur la date à retenir, et une autre sur le nombre voulu. Si tu as besoin de vérifier le nombre d'apparitions sur tous tes items, tu peux additionner les NB.SI.ENS() entre eux, car ils renvoient des nombres.
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
Bonjour
après votre tableau je ne pense pas que NB.SI.ENS soit bien adapté, étant donné qu'il faut sélectionner la date dans une colonne et compter les valeurs en ligne, ce que NB.SI sait faire colonne par colonne mais pas sur l'ensemble d'un tableau, sauf en additionnant les NB.SI de chaque colonne
ce qu'on peut envisager au plus ,juste sur votre tableau, à ajuster selon besoin:
__en M1 la date à prendre en compte
__en M2 la valeur à compter

et en M3 la, formule:

=SOMMEPROD(($A$2:$A$8=M1)*($B$2:$L$8=M2))

ce code exige des champs ,limités par des N° de colonne comme A2:A8 mais pas des (A:A ou B:B)
il faut aussi que les lignes du 1° item, champ date, soient les mêmes que celles du champ des nombres, (ici 2 et 8)

crdlmnt
Messages postés
12
Date d'inscription
vendredi 17 juin 2016
Statut
Membre
Dernière intervention
30 juin 2016

Merci beaucoup pour votre réponse ça a fonctionné!
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
Parfait,, alors je passe le sujet en résolu
Bonne route
crdlmnt