Fonction SI, valeur si vrai=résultat d'un calcul mathématique

Résolu/Fermé
Yakafocon88 Messages postés 2 Date d'inscription lundi 13 juin 2016 Statut Membre Dernière intervention 13 juin 2016 - 13 juin 2016 à 22:09
Yakafocon88 Messages postés 2 Date d'inscription lundi 13 juin 2016 Statut Membre Dernière intervention 13 juin 2016 - 13 juin 2016 à 22:31
Bonjour,

Je suis novice en Excel et cherche à faire apparaître le résultat d'un calcul si ma condition est respectée.

1ère question : faut-il utiliser la fonction SI ?

Par exemple, si dans ma cellule A1 il y a écrit "oui" je veux qu'excel m'inscrive dans la cellule A13 le résultat de cette formule =(A6-A9)/(A10-A12)*100 ; s'il y a écrit "non", je veux le résultat d'une autre formule.

J'ai tenté ce code : SI(A1="oui";A13=(((A6-A9)/(A10-A12))*100);A13=(((A9-A2)/(A4-A3))*100)) mais le résultat est "FAUX"

Parfois ça se joue à quelques parenthèses ou symboles mal placés .... Ou alors la fonction SI n'est pas adaptée ...

Merci de votre aide !!!
ps : si j'y arrive, je gagne la reconnaissance éternelle de ma chef (oui bon c'est ce que je crois)! Je compte sur vous!

Yakafocon

1 réponse

eriiic Messages postés 24467 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 1 décembre 2022 7 143
Modifié par eriiic le 13/06/2016 à 22:25
Bonjour,

tu as presque tout bon.
Tu n'as pas à mettre =A13, mettre ta formule est dans cette cellule qui prendra donc le résultat du calcul.
=SI(A1="oui";(((A6-A9)/(A10-A12))*100);(((A9-A2)/(A4-A3))*100)) 

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
0
Yakafocon88 Messages postés 2 Date d'inscription lundi 13 juin 2016 Statut Membre Dernière intervention 13 juin 2016
13 juin 2016 à 22:31
Merci beaucoup Eric ! Pb résolu
0